Skip to:

All Child Forum – Page Not Found

  • josuawahyudi


    Hi all,

    i’m totally not an IT guy, so i don’t know anything about coding. I learn to build website with WP by learning from internet.

    this is my first time i use BBpress to build a forum website.

    this is my web:
    i use WP version 4.0
    i use theme Skeleton:

    i use these plugins:
    – akismet
    – easy WP smtp
    – simple local avatars
    – simple shortcodes (reccomendation fro the theme)
    – WP-members
    – WP-pagenavi (reccomendation from theme)

    i found that all my Child forums having problem: page not found

    this is what i’ve already done:
    – reset the permalinks
    – deactivate all plugin (include bbpress), activate only bbpress

    all isn’t working

    need the solution desperately… anyone can help me? it will be a huge appreciation from me

Viewing 5 replies - 1 through 5 (of 5 total)

  • Robin W


    Presuming you have default permalinks (don’t worry if you have no idea what this means) then it is a known issue with wordpress 4.0 and is in the queue for a fix on the next release.

    in the meantime you can either

    move you child themes up a level

    or (better) change your permalinks to ‘pretty’ ones.

    see for explanation of what a permalink is

    go to

    Dashboard>settings>permalinks and set them to ‘postname’



    hi robin,

    many thanks for your respond.
    yes i use default permalinks…

    i just change it to “postname” and the result: all the parent & child forum cannot work

    this is the message i got:
    The requested URL ****** was not found on this server
    Apache Server at Port 80

    looks like i just got to use 1 level forum only?



    after i change the permalinks into “postname”, there is message in my dashboard: “You should update your .htaccess now.”

    what should i do with my .htaccess?



    just resolve my problem!

    this is what i do:

    1. change my permalinks to “postname” just like robin suggested
    2. i create “.htaccess” file (since i dont have that file)

    this is how to create that file:
    – simply open your notepad
    – copy paste this code:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    – save as “.htaccess” (you will get file with extension txt)
    – copy file with FTP to sites/domain/www
    – rename file, erase txt extension

    my child forum is active now!

    Robin W


    great – glad you’re fixed !

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Skip to toolbar