Skip to:

404's for non-admins

  • John James Jacoby


    For users that are experiencing 404 issues for non-admins, it’s likely another plugin that’s causing the problem. In some cases, it might actually be BuddyPress, as I found a bug and fixed it yesterday. 🙂

    If you’re having these issues, share what plugins you have active, and let’s see if we can sniff out what’s going on together.

Viewing 25 replies - 1 through 25 (of 26 total)

  • Debra


    Just chiming in here for the record. My knowledge of code and plugins is novice at best and I’m afraid I will not be of any help.

    I received these 404 errors with a fresh install of bbPress a little over a week ago. My membership plugin, Digital Access Pass, kept tripping it up. The DAP support team did some testing and could not come up with a solution for me. They suggested I use the fix from until something else could be figured out.



    I got this once, and also a 500 error, but I only installed recently Milat jQuery Automatic Popup and Google XML Sitemaps. Maybe I shouldn’t have installed Google XML?



    Forum links were not working for non admin’s (when logged in).
    In my case it was caused by the ‘Better WP security’ plugin.

    WP 3.5.1
    Better WP Security 3.4.8
    bbPress 2.2.4



    I have the same problem.

    Kitty Kilian


    Yup, I just switched over from SimplePress to BBPress and I have this issue.
    I switched off all plugins except Premise – which I need to give my students entrance to the member site – and nothing gives. They still get the 404.

    Kitty Kilian


    PS and yes, even with Premise switched off it gets you a 404 instead of asking you to login (which I guess it ought to)



    I have the same problem and I am currently using the following plugins:

    Avatar Manager


    Contact Us Form

    Email newsletter

    Official StatCounter Plugin

    Page Links To

    Simple Facebook Connect

    WP e-Commerce

    Any ideas?

    Neena Shaju


    I have the same problem. Please



    I have a 404 problem with pagination on topics archive pages, for both admins and non-admins. The first page display correctly, but get a 404 errors on subsequent pages:


    I am using a custom `archive-topic.php` on my theme and using the following plugins on WordPress 3.5.1:

    bbPress 2.2.4
    BuddyPress 1.7-beta2
    User Switching 0.7.1
    WordPress Post Type Archive Links 1.1
    WordPress SEO 1.4.4

    I have disabled all plugins and switched the theme to TwentyTen with flushing rewrite rules on every steps with no success. I have also changed the permalink structure to default `?post_type=topic&paged=2` and still not working.

    On my attempt to debug `$wp_query`, at the `pre_get_posts` action hook, everything looks OK:
    [query] => Array
    [paged] => 2
    [post_type] => topic

    [is_archive] => 1

    [is_404] =>
    However at `template_redirect` action, query looks like:
    [query] => Array
    [paged] => 2
    [post_type] => topic

    [is_archive] =>

    [is_404] => 1

    I only tried that with topics pagination, not forums or replies.




    I have the same problem but the link corrupt are simply bbpress topic link with “soundmanager2.swf” final suffix.
    Example the right link is “http://mysite.tld/forums/topic/hello” but user go to 404 page because they have the link http://mysite.tld/forums/topic/hello/soundmanager2.swf !!!

    I am nerd… i hope this news can help you to resolve.

    Kitty Kilian


    Hello? John?




    I experienced the same with Better WP Security 3.4.8 like @twcvols (and @banica ?) with bbpress-rc1-4831 and figured out that it conflicts especially with these functions of Better WP Security (problem stops if you disable them):

    Systemtweaks -> Dashboard Tweaks -> all three functions:

    • Hide Theme Update Notifications
    • Hide Plugin Update Notifications
    • Hide Core Update Notifications



    Having the same problem here:

    Tried the quick-fix in my functions.php, but it screwed up everything else and destroyed redirects.

    I have the following plugins:

    • All in one Favicon
    • Autotags
    • bbPress
    • bbPress Admin Bar Addition
    • bbPress Settings
    • bbPress WP Tweaks
    • bbPress Search Widget
    • Select Find and replace
    • Google Plus
    • HTML Regex Replace
    • Jetpack by
    • Select Real-Time Find and Replace
    • WordPress SEO
    • WPEssence Bulk Categories
    • YouTube

    @fagiano1973 I can’t reproduce the ‘topic looks like a filename’.

    Can you provide some more info that would help us reproduce it and/or try bbPress 2.3 RC1

    @kitty-kilian Can you create a new user after disabling all plugins except bbPress thus trying to recreate what happens in what would be a ‘standard user’ in a ‘standard’ bbPress installation without any plugins modifying WP/bbP user roles.

    PS and yes, even with Premise switched off it gets you a 404 instead of asking you to login (which I guess it ought to)

    You should not be seeing a 404 in this scenario either.

    @banica & @intellectteams As there are numerous problems listed in this thread related to 404’s you will need to explain your setup and the errors you see in more detail please.



    Before you respond to my thread…I resolved the issue by disabling the “Find and Replace” and
    the “HTML Regex Replace” plugin. Hope this helps someone else.

    @thequiet Thanks 🙂

    @nikitajaye Can you try disabling all your plugins except bbPress and see if you still see 404’s.

    I’m on a roll… So… @wdfee Thanks for that heads up 🙂

    @notebookingpages Sadly, this and that fix are still beyond my skillz 😛

    @drrxa Can you please create a ticket on Trac



    i found out what was the problem for me, this could be a bbpress bug. In wp_options in database i found a column named wp(tableprefix)_user_roles, in the array there was missing two roles bbp_participant and bbp_moderator.

    add this. and don’t forget to tell the big array that there’s one more array in the array.




    Hi, I have exactly this Problem. Visitor can see the forum, normaly registered user got an 404 page if they try to open the forum. The next problem is, that I, with admin rights can´t create any topics. I got the message “you don´t have rights to do this”. At the dashboard I´m not able to edit topics or replies, there is no point to edit this, it´s missing. In the profile I can see that I should have admin rights. This problem is since 4 days suddenly.
    What I have changed at my comfiguration is the AddHandler, I disabled it, because I had problems with the registration of Buddypress. Perhaps this could have to do anything with the problem, I don´t know.
    The plugins I use are:

    AJAX Thumbnail Rebuild
    Antispam Bee
    bbPress Antispam
    bbPress Moderation
    bbPress Unread Posts
    Blubrry PowerPress
    Broken Link Checker
    Buddy-bbPress Support Topic
    BuddyPress Activity Plus
    BuddyPress Extended Friendship Request
    BuddyPress Google Plus
    BuddyPress Like
    BuddyPress Live Notification
    BuddyPress Media
    BuddyPress Template Pack
    BuddyPress Twitter
    CodeStyling Localization
    D64 LSR-Stopper
    Download Manager
    GD bbPress Tools
    Google Analyticator
    Google XML Sitemaps
    NextGEN Gallery
    Optional Content Plugin
    Semisecure Login Reimagined
    Simple Local Avatars
    Theme My Login
    Uji Countdown
    User Role Editor
    Welcome Pack
    WordPress Ping Optimizer
    WordPress Social Login
    WP CleanFix
    WP Super Cache
    WP to Twitter

    I hope it helps, you are my last chance to fix this problem, I asked in a lot of other forums but nobody could help me.



    Now everything works for me. The only thing I made, I tested some backup plugins for wordpress.

Viewing 25 replies - 1 through 25 (of 26 total)
  • You must be logged in to reply to this topic.
Skip to toolbar