Skip to:

404 Error at step 4 of installation

  • I’m trying to install bbpress at a test site,

    – I uncompress the files

    – I then upload the files to my root directory, in a folder “forum” (so the files are at

    I can’t get any further. When I navigate to, I get a 404 error. It is as if my site isn’t seeing any of the uploaded files.

    Any help is much appreciated.



Viewing 8 replies - 1 through 8 (of 8 total)

  • chrishajer


    If you are getting a 404 at the URL you’re trying, then the files are not really there. OR you have some weird permalink/rewriting thing happening with your website. Only you can tell where it’s really uploaded. If you can post a screenshot of a file listing (from an FTP program or similar) then maybe someone can help you find the installation.



    This was something similar recently:

    Thank you for the replies.

    Here is a Filezilla screenshot showing my WordPress root directory (also the root directory of my site), with the subdirectory “forum” being the directory with the bbpress files:

    And here is what my forum (bbpress) directory looks like:

    Here are my WordPress permalink settings:

    And here is my .htacess file:

    The odd thing is that I got BBPress up and running a few weeks ago on another site (on another host) just fine. I figure it’s got to be that I’m doing something stupid, or this host has something strange with their settings.

    Thanks again for your help.



    Thanks for the screenshots, those are perfect. There doesn’t seem to be anything weird with the .htaccess or permalinks settings, and it looks like you are accessing the proper directory.

    As the other thread mentioned, there were public HTML files in two locations on the server, and that poster had installed into a directory that was not being served, making it look like the files were not there.

    One thing that is probably unrelated – the forum files have loose permissions. The directories have 775 and they should be 755, and the files (php, css, js, images) should have 644, but they have [edit] 664. Should not matter, but some hosts won’t serve content when the permissions are too permissive.

    Please do a test. Put a html file in the WordPress root (where the forum directory is located) and see if you can access it at If that comes up, put another file in the forum directory, and see if you can access that at That will ensure we are looking at the correct directories. The file can be as simple as this:

    <html><head><title>WordPress test</title></head><body><p>Test WordPress</p></body></html>

    Save that as test.html in the WordPress root. See if you can access it by URL. Then try the same in the forum directory.



    I see phpBB installed there now?

    Thanks for the suggestions. (Yes, you see phpBB there – I wanted to see if it was a bbpress issue or a server issue. I moved bbpress over from the forum directory to the bbpress directory – still the same problem, although phpbb installed fine).

    It looks like it was the permissions issue- I changed the bbpress directory and the bb-admin directory to 755, and the install.php file to 644, and the installer came up! I’m off to see if it works now.

    Thanks again for your help!

    I am glad i read this post while waiting for upload of bbpress to finish. I am new to this game, do i have to create a database for a forum or it creates itself?.



    You need a database first, then provide those database details to the installer.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Skip to toolbar