Skip to:

1.0 Alpha – Wp Integration messed logins

Viewing 10 replies - 1 through 10 (of 10 total)

  • _ck_


    Other people have done this successfully.

    I suspect one of the three keys in the config files or the secret key in the database are not in sync between the two.

    Hi ck! (great integration guide, BTW)

    I managed to make a basic integration with bbpress 1.0 alpha and wp 2.6.1 beta2.

    However bbpress reported an error in line 19 of its config file.

    Checked and it was the cookie keys that are not well fetched. Perhaps it is a problem with foreign computers and character encoding, I don’t know.

    Where it says;

    define('BB_SECURE_AUTH_KEY', '1234´´´56789');

    it is appearing;

    define('BB_SECURE_AUTH_KEY', '1234');

    Maybe the ticks and php. I solved this issue by copy pasting the right keys from wp config file.



    Where did you originally generate the keys, from the WordPress random url? I’ll report that bug to them if that’s where you got them from.



    Normally the WordPress API version 1.1 escapes those properly so you can use all manner of special characters in the keys.



    Not necessarily. The don’t escape backtick which in PHP can sometimes indicate a shell. There may be some kind of condition where it’s being parsed incorrectly. I suggested they take backticks out of the api but I guess they don’t agree.

    Where did you originally generate the keys, from the WordPress random url? I'll report that bug to them if that's where you got them from.

    Yes, keys are from the WordPress random url. I’m not sure if this is a bug, I think ¡t’s a problem with bbpress utf-8 encoding and foreign computers that are iso-whatever.

    Besides, I’ve found more problems in my bb 1.0alpha – wp 2.6.1 b2 integration attempt;

    1 I can’t find a secure key salt in the last wp version.

    2 Logins integration seems to work fine but as soon as you include


    all is messed; I lost the settings link on the dashboard, add new topic didn’t work, when no logged in I get this meesage instead of the last poster of a topic;

    Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in D:wampwwwwordpressbbpressbb-includesbackpressclass.bpdb.php on line 360

    I’ll report more errors if I find any

    Sam Bauers


    If there is no secure salt in WordPress then you don’t need one in bbPress. I think it says that in the note on that field in the installer.

    Well, since logins didn’t work I thought it was the missing secure salt, but it could be anything

    I faced the same problem, when installing bbpress 1 alpha with integration options (wp2.6) .

    The problem is because of automatic generated codes by wordpress api. I installed wp 2.6 and get those codes through api. I had bb-login.php problems when I installed bbpress 1 alpha. And I changed wp codes written in wp-config.php to simple ones( I removed some special characters such a ),”,],/,,[,},{ ) , and then it worked.

    I hope this helps you too.



    Here is another place that will generate random passwords and has the option to include just alphanumeric characters, upper and lower or just all upper.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.
Skip to toolbar