MartinM60 (@martinm60)

Forum Replies Created

Viewing 6 replies - 1 through 6 (of 6 total)

  • MartinM60
    Member

    @martinm60

    Settings are set at 50 in the bbp_forums _per_page. Admin settings are also at 50.

    WordPress settings are not limiting posts.

    What confuses me most is that if I reduce these settings below 5, the displayed forums do not change..

    What is more, there is no ‘next page’ tag to allow users to go beyond the 5 forums which are showing.

    Topics are also limiting at 5., with the forum showing 1-5 of 37 topics, but no means to go beyond the first 5.

    Any suggestions welcome.


    MartinM60
    Member

    @martinm60

    Tried disabling all plugins. Again no change..

    Something seems to be setting a fixed 5 forums display providing there are 5 forums available. Since even if I reduce the setting to less than 5, then nothing changes and the five forums remain on the page.


    MartinM60
    Member

    @martinm60

    I have the same problem.

    Only 5 forums show on the forums page. I found the setting in the bbp-core-options.php file. This is set to 50.

    If I amend to 2, there is no change, still 5 forums displaying.

    Any suggestions to resolve this?


    MartinM60
    Member

    @martinm60

    I have resolved this by editing the bbp-template.php file.

    Anyone else with the issue should look to the function: bbp-list-forums and replace the separator ',' with '<br />'

    Hope this helps

    In reply to: forums list

    MartinM60
    Member

    @martinm60

    I had this problem, and resolved it by editing the bbp-forum-template.php file.

    You need the bbp_list_forums function at about line 637..

    Find:

    // Defaults and arguments

    $defaults = array (

    ‘before’ => ‘<ul class=”bbp-forums”>’,

    ‘after’ => ”,

    ‘link_before’ => ‘<li class=”bbp-forum”>’,

    ‘link_after’ => ”,

    ‘count_before’ => ‘ (‘,

    ‘count_after’ => ‘)’,

    ‘count_sep’ => ‘, ‘,

    ‘separator’ => ‘,’,

    ‘forum_id’ => ”,

    ‘show_topic_count’ => true,

    ‘show_reply_count’ => true,

    );

    If you edit the ‘seperator line, replacing ‘,’ with '<br />'

    Then you will list your forums as required.


    MartinM60
    Member

    @martinm60

    OK, thanks for that.

    Can you give me some pointers as to where and what needs editing?

Viewing 6 replies - 1 through 6 (of 6 total)