Deadpan110 (@deadpan110)

Forum Replies Created

Viewing 2 replies - 1 through 2 (of 2 total)
  • @musnake – as you are not using sub domains, the only thing i can see wrong with your setup is the:

    $bb->logged_in_cookie = 'wordpress_logged_in_blah3_blah5_blah8';

    Try changing to:

    $bb->logged_in_cookie = 'wordpress_logged_in_';

    Im not sure if I have set my bbPress 1.0.alpha2 to work with WordPress MU 2.6.3 correctly, but its working. = my WordPress MU = bbPress sub domain

    As you can probably see, there are things within the config files that might not be needed.


    define('AUTH_KEY', 'authkey');
    define('SECURE_AUTH_KEY', 'secureauthkey');
    define('SECURE_AUTH_SALT', 'secureauthsalt');
    define('LOGGED_IN_KEY', 'loggedinkey');
    define('SECRET_KEY', 'secretkey');
    define('SECRET_SALT', 'secretsalt');
    define('LOGGED_IN_SALT', 'loggedinsalt');

    I copied and pasted the existing lines straight into bb-config.php replacing what was already there and then added the BB_ to each.


    define('BB_AUTH_KEY', 'authkey');
    define('BB_SECURE_AUTH_KEY', 'secureauthkey');
    define('BB_SECURE_AUTH_SALT', 'secureauthsalt');
    define('BB_LOGGED_IN_KEY', 'loggedinkey');
    define('BB_SECRET_KEY', 'secretkey');
    define('BB_SECRET_SALT', 'secretsalt');
    define('BB_LOGGED_IN_SALT', 'loggedinsalt');

    In BOTH bb-config.php AND wp-config I added:

    define('COOKIE_DOMAIN', ''); // remember the '.' prefix
    define('COOKIEPATH', ''); // this is empty

    Then I visited (Settings > WordPress Integration) and scrolled down to ‘Manual bbPress config file settings’ and copied all the text below ‘WordPress cookie integration speedup’ and pasted into bbPress/bb-config.php.

    $bb->wp_siteurl = '';
    $bb->wp_home = '';
    $bb->cookiedomain = '';
    $bb->cookiepath = '';
    $bb->authcookie = 'wordpress_LEFT_THIS_ALONE';
    $bb->secure_auth_cookie = 'wordpress_sec_LEFT_THIS_ALONE';
    $bb->logged_in_cookie = 'wordpress_logged_in_'; // DELETE the hash part
    $bb->admin_cookie_path = '/bb-admin';
    $bb->core_plugins_cookie_path = '/bb-plugins';
    $bb->user_plugins_cookie_path = '/my-plugins';
    $bb->sitecookiepath = '';
    $bb->wp_admin_cookie_path = '/wp-admin';
    $bb->wp_plugins_cookie_path = '/wp-content/plugins';

    Oh, and I added the$bb->wp_table_prefix = 'wp_'; too.


    $bb->logged_in_cookie = 'wordpress_logged_in_';

    The hash was removed and the line reads EXACTLY as above.

    To test, just make sure you are logged out of both and then log in and visit your other site.

    Final Note, as stated above – there is probably a lot of unneeded clutter in the bb-press config, but all works for me – no matter which domain I log into!

    I hope this helps someone :)

Viewing 2 replies - 1 through 2 (of 2 total)