Skip to:
Content
Pages
Categories
Search
Top
Bottom

Warning: require_once(bbp-converter.php)

  • I have converted from phpBB to bbpress with luck.

    But everytime my forum converted users want to login they get this error:

    Warning: require_once(bbp-converter.php) [function.require-once]: failed to open stream: No such file or directory in /home/surfogki/public_html/wp-content/plugins/bbpress/bbp-includes/bbp-user-functions.php on line 1466

    Fatal error: require_once() [function.require]: Failed opening required ‘bbp-converter.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/surfogki/public_html/wp-content/plugins/bbpress/bbp-includes/bbp-user-functions.php on line 1466

    Normal made users can login as normal. how do i fix this?

Viewing 8 replies - 1 through 8 (of 8 total)
  • This has been patched #1886 and will be in the 2.12 release later this week.

    • This reply was modified 1 year, 11 months ago by  Stephen Edgar.

    2.12 did not resolve this issue??

    but i resolved it by changing the name of the file phpBB.php to Phpbb.php in wp-content/plugins/bbpress/bbp-admin/converters

    It should have resolved the issue, did you clear your cache first?

    If so could you rename the file back and post the error you are getting here then rename the file again so you have a work around whilst we investigate this further.

    Cheers,

    Stephen


    DevArthran
    Member

    @devarthran

    I can confirm with 2.12 it still doesnt work. Fresh install from the plugin directory. Imported from vBulletin and then when a user logs in the following error is given:

    Warning: require_once(bbp-converter.php) [function.require-once]: failed to open stream: No such file or directory in /home/devnet/public_html/wp-content/plugins/bbpress/bbp-includes/bbp-user-functions.php on line 1466

    Fatal error: require_once() [function.require]: Failed opening required ‘bbp-converter.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/devnet/public_html/wp-content/plugins/bbpress/bbp-includes/bbp-user-functions.php on line 1466

    Doing investigation, seems that line 1466 which is:require_once( bbpress()->admin->admin_dir . ‘bbp-converter.php’ ); Is getting confused at the locations?

    @DevArthran There has since been another update and unless you downloaded the version you are using from the ‘SVN Trunk’ you wont have the latest patches.

    You can download an updated version of bbp-user-functions.php (4141) which has worked for a few others it will be in the next update of bbPress.

    It would also be great to get some feedback on the vBulletin import as we have had very little feedback thus far from anyone migrating from vBulletin to bbPress.


    DevArthran
    Member

    @devarthran

    That, has worked perfectly!

    Import went perfect (once i remember to point to the IP of my site and not the domain as I’m using a CDN). All users imported, all content imported. Obviously my vB was set up with a ton of permissions we now dont have. Also not sure if deliberate, but forums that were childed are now not and I had to spend an hour re-organising all the forums. Apart from that it was really smooth

    Thanks, very happy it went well for you (and us?)

    • Obviously my vB was set up with a ton of permissions we now dont have.
      At this stage that would be quite tough to migrate those ;)
    • Also not sure if deliberate, but forums that were childed are now not and I had to spend an hour re-organising all the forums.
      It is a ‘known issue’ also with phpBB, hopefully in the future we can fix this.

    Laurens Offereins
    Participant

    @offereins

    Wanted to say thanks for the patch. Conversion from phpBB works great now :)

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.