Skip to:
Content
Pages
Categories
Search
Top
Bottom

users’ email address

Viewing 9 replies - 1 through 9 (of 9 total)

  • ardentfrost
    Member

    @ardentfrost

    do something like this:

    $result = get_profile_info_keys();

    foreach ($result as $key => $label ) {

    if ( $key == 'user_email' )

    echo $label;

    }

    That needs to have some way to pull in the user you’re trying to get though… hmm. It should be close though.

    I guess I am lucky and view the users in WP because of the integration. It would be nice to have that information show up in the admin though.

    Trent

    Temporary fix (REQUIRES CORE HACK).

    Go to bb-admin/admin-functions.php and edit line 288 from:

    function display( $show_search = true, $show_email = false ) {

    to

    function display( $show_search = true, $show_email = true ) {

    That will get it showing the the admin area under users. There might be an easier way or a setting to change without this core hack, but the functionality was already built in.

    Trent

    Cool! But how come some users’ email addresses show as just “1″?

    </tr> <tr id='user-3'>

    <td>3</td>

    <td><a href='http://sostomates.fr/bar/profile/3'>Kronenbourg</a></td>

    <td><a href='mailto:1'>1</a></td>

    <td>2006-12-21 10:54:46</td>

    <td><a href='http://sostomates.fr/bar/profile/3/edit'>Edit</a></td>

    </tr> <tr id='user-25'>

    <td>25</td>

    <td><a href='http://sostomates.fr/bar/profile/25'>Oliv</a></td>

    <td><a href='mailto:1'>1</a></td>

    <td>2007-01-01 18:32:56</td>

    <td><a href='http://sostomates.fr/bar/profile/25/edit'>Edit</a></td>

    For me, as well as Trent because we are WP and BB integrated.. for some reason in the USERS section of the WP-ADMIN panel, for the user’s email addy, it displays “1″ as well..

    Any thoughts on this? Any possible way to fix this.. or will the fix that you provide above work, Trent? Meaning, once we’d do that fix you gave above, the user’s email addy will then show in the WP-ADMIN => USERS email addy box…

    Either way though, this CORE HACK would have to be applied after each bbPress upgrade though!.. (Unless of course, there were no changes to that file between releases).. I’ve been getting the SVN commits lately, and I think it was one that was “changed”.. so.. please keep this mind too!

    spencerp

    I am sure there must be a way to make this a plugin fix. Let me think about it!

    Trent

    Also, please note! If you’re running WordPress version 2.1 alphaX, or now it’s in Beta state, and you have the bbPress Integration plugin going on it..

    find this line:

    require_once( ABSPATH . WPINC . ‘/registration-functions.php’ );

    change it to this:

    require_once( ABSPATH . WPINC . ‘/registration.php’ );

    (The devs renamed the file in the includes/ directory for 2.1)

    This is probably the main cause of these errors.. Also, we’d better make sure of any other bbPress plugins using that first call to the /registration-functions.php file.. and change accordingly..

    This is for 2.1 alphaX, and now 2.1-betaX users only!!

    spencerp

    Strange….I never changed mine and don’t have any errors with alpha or beta WP 2.1……I better check it out!

    Trent

    Yeah, I’m not sure why, but while I was talking with GaMerZ on Live Messenger, he said my blog spit out an error:

    failed to open stream: No such file or directory in /home/blah/username/public_html/wp-content/plugins/

    bbpress-integration.php on line 28

    I had opened that file, and that was the line .. =/ Not really sure what, or why it was doing that, but.. after I fixed that line.. GaMerZ said there wasn’t anymore errors displaying..

    spencerp

    /I never seen that error on my site, but some how he did lol.. =/

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.