Skip to:
Content
Pages
Categories
Search
Top
Bottom

Second Page Gone!


  • brad_langdon
    Member

    @brad_langdon

    I have a topic that now spans over two pages but when I click to go to the next page sometimes it is coming up with ‘topic not found’.

    Other times it is fine and other times it is just loading a blank white screen and then the whole forum is dissapearing when I click ‘back’.

    It is very strange…can someone please help?

Viewing 7 replies - 26 through 32 (of 32 total)

  • chrishajer
    Participant

    @chrishajer

    In testing this, the host, Dreamhost, suggested turning off mod_security, which was done, but the errors persist.

    One thing I cannot understand: when accessing this URL:

    http://harrismarine.co.nz/bbpress/topic.php?id=9&page=2

    Sometimes it works, sometimes it does not. Sometimes it gives a 503 error, service not available. However, when that happens, the main site on the same server still loads fine:

    http://harrismarine.co.nz/

    Also, accessing this URL from another computer (at another location):

    http://harrismarine.co.nz/bbpress/topic.php?id=9&page=2

    is possible. So, why would a 503 error be served to some clients and not others, at the same time?


    chrishajer
    Participant

    @chrishajer

    Actually, trying to access the same URL from another client at the same IP (wget vs. Firefox, where the 503 was first seen) also works. Why would the server return a 503 to one client and not the other at the same IP?


    chrishajer
    Participant

    @chrishajer

    Looks like the 503 error was coming from the mini-track plugin (I confirmed this by changing the message slightly to see if the message was being generated by Apache or this plugin.) So far, it looks OK, but it’s only been a day. More testing to follow.


    _ck_
    Participant

    @_ck_

    The 503 is the auto-ban feature if they download too many pages too quickly. Shouldn’t happen until you pass 20+ pages and then only if you read more than 50 pages in a minute (which is crazy fast).

    But it can be disabled or increased as desired. And yes, it does block by session so another browser open on the same computer would not be banned (it’s a feature).


    chrishajer
    Participant

    @chrishajer

    Hi _ck_

    The 503 error was happening after just loading one page a couple times in a row, or going from page one of this topic to the second page. The page where the problem was first observed is http://harrismarine.co.nz/bbpress/topic.php?id=9&page=2

    You don’t need to load 100 pages in the session, or 50 pages in a minute. All you needed to do was load the first page of that topic, then try and access the second page. That’s where you typically got the 503. If you didn’t, simply F5 or CTRL-SHIFT-R would sometimes cause the 503.

    It seems like something is being counted as a page access when it’s not. It’s as if loading the first page of that topic counts as 30 page views, then loading page two is another 25 or 30 and you get the 503.

    There are lots of plugins installed. I thought at first that the bb-attachments plugin might be causing the problem since there are lots of embedded images in that topic. I know what *should* count as a page access, but it seems like some pages are being counted multiple times based on the content of that page.

    If you need more debug info or logs to see what’s going on, please ask here. Right now both those throttling things are turned off (pages in a row in a certain time period and pages per session) and the forum seems to be working fine.


    _ck_
    Participant

    @_ck_

    Ah you have the exact situation I had made a note of in the back of my mind but had not made a fix for yet because I didn’t think it would be common – bb-attachments is like a page access for every image load because it loads bbPress. You have so many images, it’s trigging the “too fast” feature.

    I haven’t addresses that yet. You can turn off the ban feature by setting these to zero:

    $mini_track_options['ban_speed'] = 0;
    $mini_track_options['ban_pages'] = 0;


    chrishajer
    Participant

    @chrishajer

    Right – that’s what we did. I figured it was related to the way the bb-attachments plugin works. Thanks.

    Weird combination of bb-attachments and mini-track at the same time.

Viewing 7 replies - 26 through 32 (of 32 total)

You must be logged in to reply to this topic.