Skip to:
Content
Pages
Categories
Search
Top
Bottom

Non-functional index page when bbpress 2.1RC4 is used with WooThemes Canvas 5.05


  • hlwinkler
    Participant

    @hlwinkler

    Hello,

    I have a slightly odd issue — with both Woothemes Canvas 5.05 on and bbpress 2.1 RC4, my forum index page is displayed as a blog archive loop of excerpts (with just one excerpt):

    http://www.politepix.com/forums/

    There is no page or post that corresponds to this “forums” URL for me to change. How can I get this displaying as a real forum index instead of a loop of excerpts?

    Thanks!

Viewing 17 replies - 1 through 17 (of 17 total)

  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    Sounds like the theme just doesn’t enable bbPress to hook in and take care of things. You’ll want to talk to Woo about bbPress compatibility. Tell them to ping me (here is fine) if they have questions.


    hlwinkler
    Participant

    @hlwinkler

    Hi John,

    Thanks very much for the super-quick answer. Yeah, I already hedged and asked them there at the same time since I couldn’t tell whether it was the new bbpress RC or the new Canvas release. I also think Canvas is a little more likely since v5 is a big overhaul — I’ll let them know they can ping you.


    hlwinkler
    Participant

    @hlwinkler

    I let them know. To follow up, it also breaks user profile pages: http://www.politepix.com/forums/profile/halle-2/


    hlwinkler
    Participant

    @hlwinkler

    Woo’s word on it is that it isn’t a bug, it’s a theming issue for me to fix. This surprises me but I’d like to just work around it at this point.

    How do I create a child theme for bbpress 2.1 that lets me address the problem that the forum index, user pages and tag pages are all displayed inside of a blog post excerpt loop with no live links or formatting?


    terence.milbourn
    Participant

    @terencemilbourn


    hlwinkler
    Participant

    @hlwinkler

    Thanks Terence! Curious about whether the instructions would be the same for 2.0 and 2.1 though.


    terence.milbourn
    Participant

    @terencemilbourn

    I’m the wrong guy to ask about that… @Doobbe is your man!


    Quang LD
    Participant

    @doobbe

    @hlwinkler Yep, 2.0 and 2.1 plugin as well


    jatinsapra
    Member

    @jatinsapra

    I am having same problem and the link @terence.milbourn shared now throws 404 Error. Any help please ?


    LabSecrets
    Participant

    @labsecrets

    Hi Gang,

    well…. this one through me for a loop today as well, when moving our WooThemes Canvas for bbPress & BuddyPress site for a test drive on bbPress 2.2 ( http://labsecrets.com/demo/canvas-commerce )

    The individual forums would work fine, but the main forum index was rendering what looked like a post excerpt, with everything jumbled into a single paragraph.

    Solution was actually rather simple. If you are using a child-theme in Canvas (you ARE using a child-theme I hope?? ;-)  ) simply make a copy of the content-page.php file from parent, and put it into your child-theme folder.

    Next, change the entry div as shown, to modify the current conditional check to ALSO see if you are on a bbPress page. Without this extra bit, it assumes that you want the page to show the_excerpt() on every page other than single.php …. not true. We want full content on bbPress pages as well ;-)

    <div class="entry">
    <?php
    /* If this is a bbPress page show full content not exerpt */
    if ( ! is_singular() && (! is_bbPress()) ) {
    the_excerpt();
    } else {
    the_content(__('Continue Reading &rarr;', 'woothemes') );
    }
    wp_link_pages( $page_link_args );
    ?>
    </div><!-- /.entry -->

    With this simple mod, all is well and now the native forums index works, and so does building a custom page with shortcode. Ta da!

    See: http://labsecrets.com/demo/canvas-commerce/forums/


    LabSecrets
    Participant

    @labsecrets

    One more thing:

    User profile was causing a problem where navigation was pushing down summary of topics and replies. Add this CSS to fix:

    #bbpress-forums .bbp-user-section {
    display: inline-block;
    width: 100%;
    }

    h646572
    Participant

    @h646572

    Thank you labsecrets! It was hard to find info on Woo support but this worked for me!

    As an aside, bbpress was broken with Atahualpa, too — maybe this is really a bug with bbpress?


    Heavenlyz
    Participant

    @heavenlyz

    Ok, so newbie here who knows html and understands coding but is really keen to not screw up the site that someone else has built for me (so apologies if the answer is above and I’m not seeing it).

    The site is http://www.heavenlyz.com and, I think, I’m using the “Nollie” theme.

    I’ve installed bbpress, created a couple of forums and – via the great info on this thread – created a page called “Boardroom”, into which I’ve inserted the “[bbp-forum-index]” shortcode. Hey presto, after much head scratching, I can now see a forum index on http://www.heavenlyz.com/boardroom/…woohoo :)

    But, my next challenge is to be able to open one of the forums shown. Am struggling with this.

    Because I am using the Nollie theme – I think – the parent/ child argument doesn’t apply, so am looking at changing the root page.php

    Above, Lab says

    Next, change the entry div as shown, to modify the current conditional check to ALSO see if you are on a bbPress page. Without this extra bit, it assumes that you want the page to show the_excerpt() on every page other than single.php …. not true. We want full content on bbPress pages as well

    But my page.php says…

    ID, ‘mfn-post-layout’, true) ) {
    case ‘left-sidebar':
    $class = ‘ with_aside aside_left';
    break;
    case ‘right-sidebar':
    $class = ‘ with_aside aside_right';
    break;
    default:
    $class = ”;
    break;
    }
    ?>


    <div id="Content" class="subpage”>


    <?php
    if( $class ) echo '';

    while ( have_posts() )
    {
    the_post();
    get_template_part( ‘includes/content’, ‘page’ );
    }

    if( $class ) echo ”;
    ?>

    Where’s the “entry div”? Apologies if this is a laughably stupid question.

    All help appreciated. N.b. As I’m learning, to start with, I’d rather keep the changes simple and effective rather than complex and golden.


    OrgSpring
    Participant

    @orgspring

    For those still struggling with the garbled forums page in a stock woothemes canvas installation (or child theme off canvas) this support post at WooThemes really helps:

    http://support.woothemes.com/entries/24051302-Fix-bbPress-forum-search-in-Canvas

    The woo team created a simple bbpress template for use in canvas and included the attached files – one template file and a some code for functions.php.

    Works like a charm.


    connielk
    Participant

    @connielk

    From the link it seems that fixes garbled search page. I don’t have a woo theme but I do have a garbled search page. That link requires purchasing a woo theme. Can you post here what the solution was?


    tkemper
    Participant

    @tkemper

    @orgspring – Is there any way you can provide me with the template and files you mentioned in the woo post? The person who created my webpage is the one who has the Woo account and now I can’t get into their support portal without login credentials to view this post and fix the problem. I’ve contacted them for help with no response.


    LabSecrets
    Participant

    @labsecrets

    You’re welcome to drop me an email to help@labsecrets.com

Viewing 17 replies - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.