Skip to:
Content
Pages
Categories
Search
Top
Bottom

Messed up WP and BB integration


  • mithrandir321
    Member

    @mithrandir321

    Hello, I’ve just messed up my work. I had WP in root and BB under /bbpress directory but I’ve decided to use BB in root and WP under /blog directory because BB suits my needs better. So I moved it around / changed the setting of both to reflect the new URL… but I can’t log in BB, it says user “admin” doesn’t exist (admin was originally created for WP which I installed first).

    My BB homepage says:

    Warning: mysql_connect() [function.mysql-connect]: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) in /home/home1/novapojistovna_cz/public_html/www/bb-includes/backpress/class.bpdb.php on line 123

    Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /home/home1/novapojistovna_cz/public_html/www/bb-includes/backpress/class.bpdb.php on line 377

    Now where do I start to fix it? Please help, thank you.

Viewing 12 replies - 1 through 12 (of 12 total)

  • chrishajer
    Participant

    @chrishajer

    From the first error, it sound like the database connection details are incorrect. Are you using a socket connection to MySQL?


    mithrandir321
    Member

    @mithrandir321

    It worked alright before I started moving around with the directories.

    If you’re talking about the params from config.php they stay untouched as they were before so BBDB_NAME, BBDB_USER etc. are correct….

    Dont’t know what a socket connection is or how it differs :-(


    mithrandir321
    Member

    @mithrandir321

    One more piece of info – connection to database works alright when it comes to forums, topics, posts (they’re all listed on homepage). But when it comes to users (which is a link to WP), it fails and gives the above error.

    Also, if I want to click through on a particular forum/topic from homepage, it gives 500 Internal Server Error

    Any idea what this could be about? Where the reason is?


    chrishajer
    Participant

    @chrishajer

    If the issue is with users only, maybe it’s because of how you integrated? An integrated installation would use the wp_users table, not the bb_ tables, right?


    mithrandir321
    Member

    @mithrandir321

    Yes, I installed WP first, then BB and integrated from the beginning, so BB is using wp_users. In fact, there’s no bb_users table according to my phpMyAdmin. Somehow, it seems that BB cannot access that wp_users table for one reason or another. But what exactly it is, is a mystery to me :-(


    mithrandir321
    Member

    @mithrandir321

    Oh, I’ve just noticed there’re 2 weird tables:

    - wp__usermeta

    - wp__users

    Both have 2 underscore marks and both are empty. Looks weird if you ask me, but dunno if it’s the problem.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Firstly, have you checked to make sure that your site paths are correct in both bbPress and WordPress? Since you shifted directories, the paths to those new directories need to be adjusted in the database.

    Secondly, are there normal user tables to go along with those weird empty ones? Part of the integration process is telling bbPress which tables to find your users in. Is it possible that you added an extra “_” on accident, and bbPress created those tables while it was looking for the real ones?


    mithrandir321
    Member

    @mithrandir321

    Yes, sitepaths in setting are correct. Normal user tables are in place, in fact I can use WP with no problems at all.

    This is so weird… Will anyone give it another try?

    the website is http://www.novapojistovna.cz (unofrtunately is in Czech)

    I would search the db for traces of old paths…

    I would remove any symlinks (like cPanel subdomains)

    Then, I would check all the .htaccess files for old information.

    A final clearing of browser cache/cookies and then start from there.


    mithrandir321
    Member

    @mithrandir321

    Okay, many thanks for that one, musnake. I checked it out with this result.

    .htaccess was full of old paths and updating solved the 500 internal server error. But it didn’t help much in the way of the database errors and I didn’t find any old path references in the DB nor in any files.

    So, while queries into the DB for topics and forums is okay, the only thing that doesn’t work is the users (my BB homepage when asked for any user data gives the above errors) – which is taken from WP shared table. So could it be that the error is in initialization global $bbdb; ???


    mithrandir321
    Member

    @mithrandir321

    Maybe I should add I’ve got BB 1alpha2 and WP 2.6.3


    mithrandir321
    Member

    @mithrandir321

    I’m now going through the WP and BB integration FAQ and it seems there is no option for BB in webroot and WP in a subdir listed there: http://bbpress.org/forums/topic/wordpress-and-bbpress-integration-101#post-17412

    Could this be wrong? Something to do with cookies? But then the BB homepage gives these errors, so I’m not even trying to log in…

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.