Skip to:
Content
Pages
Categories
Search
Top
Bottom

Firefox WP Cookies Are Not Acceptet


  • JanEllers
    Member

    @janellers

    Hi, iam Using bbPress with a WordPressinstallation. My WP install is in:

    /blog/

    and my bbPress in:

    /blog/forum/

    If I now log in in my WP with IE and go to the Forums all is fine. But if I do the same with FireFox I have to login again.

    I’am using WordPress Plugin bbpress Integration and the WordPress Integration Plugin for bbPress. Did i made something wrong?

    thanks,

    Jan

    Edit: If I’am logged in and go to the register.php with FireFox he mean that Iam already logged in… confusing…

    Edit#2: If I log out in bbPress my Iam logged out in WP too…

Viewing 5 replies - 1 through 5 (of 5 total)

  • _ck_
    Participant

    @_ck_

    You need to follow the instruction to syncronize the cookie paths in bbpress and wordpress.

    Essentially both have to be set to your site’s webroot (ie. /)

    Look under the cookie section here

    http://bbpress.org/documentation/integration-with-wordpress/

    or look through the integration tag here like so:

    http://bbpress.org/forums/topic/cookie-question-wp-bb-and-beyond


    JanEllers
    Member

    @janellers

    thanks _ck_

    But the problem is that if i logged in into my WP Site and go to the Forums my login form shows up instead of the welcome message.

    But if i go directly to a forum typing “forum.php?id=2″ i see the forum, can make new topics and instead of the login form i see the welcome message.

    So it seems like the cookies are set and working correct with bbpress but the view has any problems… same problem in the standard Theme. Private Forums Plugin is not the problem. I try to edit the config files like in the other threads but that doesn’t help and I installed all integration Plugins for bb and wp.


    JanEllers
    Member

    @janellers

    I do some more testing:

    if i use the “bb_is_user_logged_in() )” Function on the entry site it returns false every time. but if I go to the register.php wich uses the same function for displaying the content it shows: “You’re already logged in, why do you need to register?”

    If I now go back to the front page by clicking a link on the register page, bbPress recognize that I’am logged in. Due this process I never used the “Log in” Button of the Forum. I was justed logged in by my WP Site.

    Another test:

    If I login thru my bbPress site all works fine. But if i go back to my WP Site and return to the Forum I have to log in again…


    JanEllers
    Member

    @janellers

    I now solved the problem with installing the Year Long Cookie Plugin. But it isn’t a nice way because the log out functions aren’t working correctly…


    JanEllers
    Member

    @janellers

    just don’t belive in my last post :( please help me!

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.