Skip to:
Content
Pages
Categories
Search
Top
Bottom

Errors in install.php line 10 and functions.php line 1898

  • Hello there!

    I have a website with a Wp install. I made a folder called “forum” so I could add a forum to this site. I made another MySQL database ( I already have one for Wp) for BBpress and write the user, pass,etc of the new SQL in the config.php file and here starts the problems.

    1) I got the famous problem with the lost letter “i” in the line 80. Solved.

    2) Then I get two more errors:

    2.1: Warning: Cannot modify header information – headers already sent by (output started at /homepages/24/d225407794/htdocs/foro/bb-includes/db-mysqli.php:454) in /homepages/24/d225407794/htdocs/foro/bb-admin/install.php on line 10

    and 2.2:Warning: Cannot modify header information – headers already sent by (output started at /homepages/24/d225407794/htdocs/foro/bb-includes/db-mysqli.php:454) in /homepages/24/d225407794/htdocs/foro/bb-includes/functions.php on line 1898

    I try continue the installation and everything goes well, but The forum is not working. I mean. I can´t log out as the admin,I get the error:

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/24/d225407794/htdocs/foro/bb-includes/db-mysqli.php:454) in /homepages/24/d225407794/htdocs/foro/bb-includes/pluggable.php on line 37

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/24/d225407794/htdocs/foro/bb-includes/db-mysqli.php:454) in /homepages/24/d225407794/htdocs/foro/bb-includes/pluggable.php on line 37

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/24/d225407794/htdocs/foro/bb-includes/db-mysqli.php:454) in /homepages/24/d225407794/htdocs/foro/bb-includes/pluggable.php on line 164

    If I post a new topic, I go to the write new topic windows , but when I send It; get an error :Warning: Cannot modify header information – headers already sent by (output started at /homepages/24/d225407794/htdocs/foro/bb-includes/db-mysqli.php:454) in /homepages/24/d225407794/htdocs/foro/bb-includes/pluggable.php on line 164

    The strange thins, is that all those post appears in the general window!! but I can´t acces them. I get an Error 404 File not Found. The same error if I try to see my profile as admin.

    The BBpress installation has a lot of problems!!!. It´s not any easy..

    Any idea?

    Thanks in advance!

Viewing 10 replies - 1 through 10 (of 10 total)

  • chrishajer
    Participant

    @chrishajer

    Sounds to me like you edited a file (maybe db-mysqli.php) and have a blank line or a space after the closing ?> in the file. PHP doesn’t like that, so it throws that Warning: Cannot modify header information - headers already sent by error. Check any file you modified (db-mysqli.php?) for a blank line or space after the closing ?>

    Hi Chrishajer!!!

    You were right!! I had 2 blank lines after ?> and now I have NO Warnings, can Log Out, and log in, but….

    But, I can´t post. I mean, I go to the write new post screen, write a post and after send it, I get an Error 404 File not found on path..foro/topic/6?replies=1#post-6.

    The funny thing , is that if I go to the genereal forum , I can see the subject of the post that I couldn´t send!!!. If I try to read it, again file not found on…foro/topic/6?replies=1

    —-

    EDIT: I have check my site, and I don´t have the folder /foro/forum/1 neither /foro/topic/

    It´s supposed that those folder are created by the program, but Where they gone?

    You can check the forum at:

    http://www.eee-pc.es/foro/

    Thanks in advance!


    chrishajer
    Participant

    @chrishajer

    In your config.php, make sure your “mod_rewrite” line says false:

    $bb->mod_rewrite = false;

    Permalinks are not supported on your host, at least not right now. Change that line to false (maybe you have slugs or true there now?) and it should work fine.

    If things work like that, you can figure out the proper mod_rewrite rules for your .htaccess file.

    BTW – those are not real folders, they’re just URLs created by bbPress that look like folders. They won’t be in the filesystem.

    Hi !

    You were right again!! I had $bb->mod_rewrite = set to true; But I change it to false and still gatting the same error Error 404 file not found.

    But If I go to Admin–>Content–>Post–>All, I can see the post and Edit!!

    Any clue?

    Thanks again for your time Chrish!


    chrishajer
    Participant

    @chrishajer

    It still looks like it’s using pretty permalinks, according to the links I found on your forum which don’t work. Are you sure you edited and saved the correct file, config.php in your /foro directory?

    Here are some links that don’t work:

    http://www.eee-pc.es/foro/topic/6

    http://www.eee-pc.es/foro/topic/1

    http://www.eee-pc.es/foro/topic/7

    Normal links don’t look like that, just pretty permalinks.

    Hi !!

    You were right again! :-)

    I have the line

    $bb->mod_rewrite = ‘false’;

    I forgot to delete the ‘

    Now everything works PERFECT!!!

    Thank you so much!!

    Best regards fromo Spain!

    Andres

    Perfect shooting chrishajer!

    Trent


    Deesdogcare
    Member

    @deesdogcare

    OK ~ I had all the same errors occuring and most of them were resolved by following the instructions in this post. However, I cannot open any links on the page at all. Not my profile, or anything ~~~ all of them give me a ‘file not found’ error.

    Yes, I DID have permalinks enabled, but I went in and changed the line in my config.php file to false and saved the file. I’ve double checked and it did save my change.

    Thanks in advance!

    D


    Deesdogcare
    Member

    @deesdogcare

    Update ~ I can’t click any links in my wp either now. I hadn’t checked that before my last post.


    chrishajer
    Participant

    @chrishajer

    I see you started a new thread rather than continue this [resolved] one…

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.