Skip to:

No display name on front page, using the Post Meta plugin in bbPress 1.0

Viewing 4 replies - 1 through 4 (of 4 total)

  • _ck_


    Post Meta is so complex I might not be supporting it anymore under the new 1.0

    It uses a great deal of hacky workarounds to function and was kind of experimental in the first place.

    Since 1.0 now really does have post meta ability (at least in the database) you might want to try making something work with that.

    As a side note I find all these “has anyone figured how to make so-and-so work under 1.0” questions very strange. People should not be using 1.0 so soon unless they know how to figure it out themselves. Also 1.0 has also only been out a few days, not even a week, how many people does everyone think are rushing to upgrade to 1.0 so soon?

    The way some plugins will be broken under 1.0 is non-trivial. There are database changes, hook changes, the way data is moved around has changed, cache system has changed, variables are renamed. It’s a different creature than 0.9, not a simple upgrade. The numbering system is very misleading – 0.9 is really 1.0 and 1.0 is really like 2.0



    For what it’s worth, I’m taking your advice _ck_, and sticking with 0.9 for the foreseeable future. I don’t want to loose all the functionality the current plugins give.

    I have to agree about the version names too. Renumbering 0.9 to 1.0, then making the new version 2.0 may have given people a bit more pause for thought before gleefully installing the new version. The numbering gives the appearance of being a minor upgrade, when obviously it isn’t. Not that it’s an issue for experienced users, but the sudden flood of “Why doesn’t this plugin work now?” questions wasn’t hard to see coming, was it?



    I appreciate it when people listen to my advice. I wish more people did, I am getting a few people a day now asking how to fix so-and-so because they upgraded to 1.0 and it’s getting tiresome.

    In some cases they never saw my warning which is unfortunate but the ones who saw my warnings and figured they knew better or I would somehow drop everything and fix it anyway, well I don’t know what to say.

    buddha trance


    _ck_, I was fully aware when I upgraded, which I did first on a test install. I am glad I did. Everything works beautifully and it was worth it. All the plugins I am using are working fine. There is only this minor glitch and I thought it was clear enough that I understood you are not supporting the plugins with the new version, and that the question was not addressed to you, not to bother you. I said it’s understandable that you are not, and in no way I was expecting that you drop everything, nor I was thinking that I knew any better.

    I am very grateful for the plugins you have written and that I am still using on 1.0. There is nothing wrong with asking if other testers (starting from the alpha) are also using the anonymous feature and if the display name was working for them. It’s a support forum, after all!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar