Skip to:
Content
Pages
Categories
Search
Top
Bottom

wrong password


  • annagb
    Member

    @annagb

    The bbPress forum I installed sometimes sends wrong passwords to new users.

    I mean, the user receive a password, but this password does not work. So I have to change the password as admin and to tell them the new one.

    May this depend on a plugin? Is there any solution to this problem? Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)

  • chrishajer
    Participant

    @chrishajer

    I’ve never had that problem. Can you post a link to your forum, so we can register, then see what happens when we try to log in?

    Thanks.


    annagb
    Member

    @annagb

    http://www.astisti.it/forum

    I tried to register and once it happened that the password was wrong… But most of my tries worked.


    chrishajer
    Participant

    @chrishajer

    Looks like you’re using the Approve Registration plugin (my account is on hold right now.) I would turn that off and see if passwords work properly. If they do, then it’s likely this plugin causing problems.

    The other possibility is that it’s due to a language file, since this forum is in Italian.


    annagb
    Member

    @annagb

    I use Approve Registration plugin. So I will try to turn it off. Thank you. I think that to change the language is more complicated. Do you think that the problem may be caused by both these things together?

    Anyway I approved your registration if you want to try if your password is right or wrong.


    chrishajer
    Participant

    @chrishajer

    I did receive my password, thanks. The password that was sent does not work though. It appears that the password is not the proper length. Maybe the approve registration plugin is mangling the password somehow, chopping off some characters or stripping some out.

    Here is a good password from another forum:

    Nq@bDVwS!APP

    Here is the one I received from your forum:

    et@ORSFzWx

    I changed one or more characters in each password. It’s the length I don’t like.


    annagb
    Member

    @annagb

    I see. I also thought that the length was strange and also a user of the forum told me. So now I turn of the plugin, hoping that it is the cause of the problem. If it is not I have to think about the language… Do you agree? Thank you.


    chrishajer
    Participant

    @chrishajer

    Try one thing at a time. Let me try registering again and see what the password looks like this time.


    chrishajer
    Participant

    @chrishajer

    With the plugin turned off, I received the password promptly and it worked. I would place a bet on that Approve Registration plugin causing the trouble.

    Also, the password message I received has some odd looking characters in it.

    Il tuo nome utente è: myusername
    La tua password è:

    The password email arrived with è in it twice, just like above.


    annagb
    Member

    @annagb

    I hope that the cause is really the plugin.

    The message depends on the language, obviously. Do you think it could be corrected?

    I will let you know if I will have again problems with the password. The reason for which I am not sure that the cause was the plugin is that sometimes the password was correct also with the plugin turned on.

    Thank you!


    chrishajer
    Participant

    @chrishajer

    I think the reason it was correct sometimes would be due to the content of the password. bbPress originally (or a while ago anyway, pre-0.9*) used a 6 character alpha-numeric password. Now, it uses something more complex, and depending on what characters are in the password, maybe some certain characters get dropped in that plugin. If you post a link to the plugin you’re using, I can look at it and see if this is likely. You could also contact the plugin author and see if they have any idea.

    On the special characters in the password email. I suspect the message is just sent as plain text, but those are html entities. I didn’t look too hard at it. Maybe you could just put the รจ in the text of the message and hope the email client can handle it.


    Anonymous

    I also think it has to do with a plugin, because I’ve never had any problems with it!


    annagb
    Member

    @annagb

    I hope I understand what you asked me… The plugin I was using is “Approve User Registration”. http://bbpress.org/plugins/topic/approve-user-registration/#post-1141


    chrishajer
    Participant

    @chrishajer

    I think I would just try to contact the plugin author for help with that.

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.