Skip to:
Content
Pages
Categories
Search
Top
Bottom

wp-includes/pluggable.php on line 689


  • chadvondra
    Member

    @chadvondra

    WP 2.5, BBP .9.0.1 whenever I try to post or log into the bbpress admin I get the following error:

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/virtual/mywebsite/forums/bb-config.php:1) in /var/www/virtual/mywebsite/wp-includes/pluggable.php on line 689

    The posts acutally go through but the redirect seems to choke. Admin no can login.

    I have checked both bb-config.php and pluggable.php for blank spaces/lines after the tags. None there. I’m mucho confused. If anyone can help I would greatly appreciate it.

    Thanks in advance,

    Chad

Viewing 9 replies - 1 through 9 (of 9 total)

  • Sam Bauers
    Participant

    @sambauers

    Are you including WordPress inside bbPress?

    The failure is occurring in WordPress’ pluggable.php file, not bbPress.


    chadvondra
    Member

    @chadvondra

    Yes its an integration with WordPress.


    chadvondra
    Member

    @chadvondra

    Just to clarify I have WordPress 2.5 and BBPress .9.0.1 with the integration plugins installed.


    Sam Bauers
    Participant

    @sambauers

    Remove the integration plugins, they are not required anymore.


    Sam Bauers
    Participant

    @sambauers


    chadvondra
    Member

    @chadvondra

    Went through, disabled the Integration plugin, verified that I had already put the proper tags in and still same error. UGH. I see the /wp-includes/pluggable.php 689 error is increasing in frequency on google by the day. Anyone?


    Sam Bauers
    Participant

    @sambauers

    Is there a reason why you are loading WordPress inside bbPress? If not you should stop. There is no need to do this for standard integration to work.

    Also, remove all your plugins and see if it stops. If it does, add them back one by one to see which one is causing the problem.


    Sam Bauers
    Participant

    @sambauers

    You should really triple check for blank lines or spaces or null characters at the start of your bb-config.php file. This part of the error: output started at /var/www/virtual/mywebsite/forums/bb-config.php:1 points to that being the problem.

    You should go into the start of the file and delete <?php completely and press the delete key a few times at the start of the file. Then add <php? back to the start of the file.

    You didn’t upload your files using Dreamweaver did you? That program has an “option” to add a utf8 BOM character to the start of files, which causes similar behaviour.


    chadvondra
    Member

    @chadvondra

    I redid my bb-config.php completely. finally that did it. I used bbedit before to mod it and for love of god it didn’t want to work. Its working this topic can be closed. Thanks a ton Sam. Sorry for the headaches.

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.