Skip to:
Content
Pages
Categories
Search
Top
Bottom

There are no 404′s


  • killpack99
    Member

    @killpack99

    I’ve just installed bbPress and I’m not using pretty permalinks and for some reason I never get a 404. Which at first doesn’t sound bad but I don’t get and 404 errors, no matter what I write in the address bar. I’d like to fix it (I’ve even specified a 404 page in .htaccess) but I’m really at a loss.

Viewing 3 replies - 1 through 3 (of 3 total)

  • chrishajer
    Participant

    @chrishajer

    What *do* you get instead of a 404? Something is probably overriding the 404 and displaying a page (WordPress does that sometimes depending on the way the theme is configured.) Are you integrated with WordPress?

    And, can you post a link to your forum so someone can check the server response and see if it’s sending a 404 header but still displaying content? I recall that being a problem in the past but I can’t recall the details right now (maybe it was an IIS thing?)


    killpack99
    Member

    @killpack99

    I get the main (front) page. The url is bb.indieinvasion.net (by the way the server in running linux) Also I’m using wordpress integration


    chrishajer
    Participant

    @chrishajer

    My guess is that there is something in the WordPress .htaccess file that is causing it to mess with what should be a forum 404 error. I don’t know enough about subdomains and bbPress integrated with WordPress, but that’s my guess. Something in the WordPress .htaccess file is rewriting your bbPress 404. Possibly? Is there a .htaccess file for bbPress? I would guess not, since you’re not using permalinks for the forum.

    I suspect it has something to do with the subdomain, but that’s just a SWAG.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.