Skip to:
Content
Pages
Categories
Search
Top
Bottom

Slow down; you move too fast


  • roddaut
    Participant

    @roddaut

    Hi,

    Ever since updating to the latest bbpress plugin when users or admins try to post a new topic or reply to a topic we get the error “Slow down; you move too fast.” I’ve looked at other posts on this forum having the same issue but did not find anything that helped me.

    Also this problem happens any time anyone posts. It is not the result of someone trying to post too much too quickly. Throttle time is set for 10 seconds. And when I try to change the throttle time it reverts back to 10 seconds. Maybe that’s a clue as to what the problem is?

    Just to sum up:
    The issue exists for all users and admins.
    The issue happens for all posts – a person cannot be throttled because they haven’t succeeded in making one post.
    The problem happened only after updating bbpress but not before.

    Thanks in advance for your help.

    Rodney

Viewing 17 replies - 1 through 17 (of 17 total)

  • roddaut
    Participant

    @roddaut

    BTW I have disabled all plugins except for the bbpress plugin and our membership software so we can rule out most possible plugin conflicts as well.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Possible your server time is set incorrectly? That might cause the calculation between current_time() and the users last_active time to have a gap? Though, it probably is a deeper issue than this – could even be a bbPress GMT bug.


    matthiaswh
    Participant

    @matthiaswh

    I have run into this same issue since the latest update. I can “reset” it by changing the throttle time to 0 and saving. While the throttle time doesn’t save at 0 (defaults back to 10), the Slow Down error stops for awhile. Then it will randomly pop up again.

    It doesn’t seem to be a theme compatibility issue. I’ve set to the default bbPress themes.

    It’s not a visual editor issue. I’ve disabled and enabled and it happens regardless.

    It doesn’t seem to be a server time issue. I’ve tried it on two servers, and reset the server time to see if that helped.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    That narrows it down to the logic inside the bbp_check_for_flood() function, in bbp-common-functions.php. Would be great if y’all could help troubleshoot, and we’ll get it fixed for the next release.


    wgmccallum
    Member

    @wgmccallum

    This problem appeared when I installed the bbPress Admin Bar Addition, and disappeared when I deactivated it.


    vaantti
    Participant

    @vaantti

    I came across this problem. Has anyone resolved this? Btw. where is the Throttle time setting?


    rmazereeuw
    Participant

    @rmazereeuw

    Having the same issue as roddaut:

    Up-to-date WP install, working fine with bbpress until latest update.

    New users getting the “slow down…” error message trying to post new topics of replying to existing.

    Resetting the throttle to 0 seems to help temporarily, but it always reverts back to 10 seconds.

    Tried deactivating all plugins and no difference.

    roddaut: Which membership software are you using. We have iMember360 (aka InfusionWP)

    anyone: Is there somewhere in the php files where I can set the throttle to 0 (other than in the dashboard, which isn’t sticking)?

    vaantti: The throttle setting is under Settings > Forum

    Thanks


    matthiaswh
    Participant

    @matthiaswh

    Hey @rmazereeuw ,

    We’re using iMember360 also. We overhauled our theme, now integrating it with buddypress and a theme built on bbp-theme-compat and that seems to have resolved this problem.

    Not the answer you want to hear, but you can forcefully disable the throttle check by editing bbp-common-functions.php (this is in bbp-includes directory of the plugin). Do a search in that file for bbp_check_for_flood and make that function always return true. This obviously isn’t ideal!


    rmazereeuw
    Participant

    @rmazereeuw

    Hey @matthiaswh

    Thanks for the tip: Just to be clear, I need to change this line:

    function bbp_check_for_flood( $anonymous_data = false, $author_id = 0 ) {

    to

    function bbp_check_for_flood( $anonymous_data = true, $author_id = 0 ) {

    BTW, always helpful to be able to swap notes with another iMember360 user. If you’re interested please drop me a note at ric.mazereeuw (at) gmail

    Thanks


    matthiaswh
    Participant

    @matthiaswh

    That’s the right place in the file, but the wrong edit. You would replace everything between those curly brackets with “return true;”, so it would look like this:

     function bbp_check_for_flood( $anonymous_data = false, $author_id = 0 ) {
    
        return true;
    }
    

    This does affect a core file in the bbpress plugin, so anytime you update you will have to make this change again.

    I’ll send you an email! I have a love/hate relationship with iMember. It gave us a ton of trouble on our old host, but is working great on Synthesis WP hosting.


    rmazereeuw
    Participant

    @rmazereeuw

    Thanks, will give it a try


    roddaut
    Participant

    @roddaut

    For some reason I did not see replies to this thread so I’ve not been back until now.


    Thanks matthiaswh. That solved the problem. And since it’s a membership site for a very small class with only 20 participants at a time, it won’t be a problem for us.

    Also for those asking for more details. I originally solved the problem by going back to the previous version of bbpress. Recently I needed to upgrade bbpress to the latest version again because another plugin would only work with the most recent version.

    We use imember360 for our membership system and our theme is Twenty Ten.


    roddaut
    Participant

    @roddaut

    I guess I spoke too soon. The issue came back. Not sure why.


    roddaut
    Participant

    @roddaut

    Today I found this code between the bbp check for flood and the return true. I deleted it and I’m able to post in my forum again.

    $throttle_time = get_option( '_bbp_throttle_time' );
    if ( empty( $throttle_time ) )


    nightshift58
    Participant

    @nightshift58

    Hi guys,

    In the latest version, v2.2.2, the core file to update/change is:

    includes/common/functions.php

    All that’s needed is to comment out (//) line 718.

    Unfortunately, this function doesn’t have any actions or filters or I would have interceded that way.

    Best,
    Bob
    iMember360.com


    nightshift58
    Participant

    @nightshift58

    You can also set the “Throttle posting every” setting to 0 in Settings->Forums.

    Just remember to always overwrite the 10 with 0 **EACH** time you save settings.


    nightshift58
    Participant

    @nightshift58

    Okay, so this gave me no peace…

    I’ve been trying to bring the iMember360 forum back online after I converted it from the old standalone bbPress version.

    This throttling was the last issue (that I know of) standing in the way.

    In iMember360, I added a filter to quash the throttling issue until bbPress fixes the issue.

    Update to iM360 v3.4.016 and you should be throttle-free…

    Best,
    Bob
    http://www.iMember360.com

Viewing 17 replies - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.