Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem upgrading from 0.904 to 1.0


  • inerxia
    Member

    @inerxia

    I follow all the instructions from here:

    http://bbpress.org/documentation/upgrading/

    And get this mesage:

    “An invalid configuration file was found at bb-config.php

    The installation cannot continue.

    Usually this is caused by one of the database connection settings being incorrect. Make sure that the specified user has appropriate permission to access the database.”

    I tried with the old bb-config.php and entering the data base info ito the new one and nothing.

    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)

  • chrishajer
    Participant

    @chrishajer

    What do you mean “and nothing”? Something happened at that point right?


    inerxia
    Member

    @inerxia

    Sorry, then nothing happened.

    This is the message:

    http://inerxia.net/foro

    Thanks


    chrishajer
    Participant

    @chrishajer

    Can you paste the bb-config.php here? Just change the password details within the quotes. It’s a pretty simple error usually, and not that one of the connection details is incorrect, just that there is a problem with the file.

    Why does it appear to be installing rather than upgrading?


    inerxia
    Member

    @inerxia

    Thanks, here is the php:

    And one final question , there is a way to reinstall using the same database and directory ?

    <?php
    /**
    * The base configurations of bbPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys and bbPress Language. You can get the MySQL settings from your
    * web host.
    *
    * This file is used by the installer during installation.
    *
    * @package bbPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for bbPress */
    define( 'BBDB_NAME', 'organica_foro' );

    /** MySQL database username */
    define( 'BBDB_USER', 'organica_ineFORO' );

    /** MySQL database password */
    define( 'BBDB_PASSWORD', '********' );

    /** MySQL hostname */
    define( 'BBDB_HOST', '' );

    /** Database Charset to use in creating database tables. */
    define( 'BBDB_CHARSET', '' );

    /** The Database Collate type. Don't change this if in doubt. */
    define( 'BBDB_COLLATE', '' );

    /**#@+
    * Authentication Unique Keys.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/bbpress/ WordPress.org secret-key service}
    *
    * @since 1.0
    */
    // edited keys chrishajer 19 March 2010
    define('BB_AUTH_KEY', 'gUpvcuMfP+tDsXUus|(|9|/G4Owo@=;C697V[[ZPd+|W)BVK-[U,fi/H2r+VOj');
    define('BB_SECURE_AUTH_KEY', 'sf8;HNH}7%N#_|=$d4(_(yV8Wt&R($kL+)JS@}Kno-Q2jfkOm|BUL-i**&f_Wg');
    define('BB_LOGGED_IN_KEY', 'm}Xc?tvc 3;o)JUVdxDm%F[V96V<+zyka239SbV<^2)o[/tV>Q4&kW$B4ik(NA');
    define('BB_NONCE_KEY', ';k,c^0G4nz9eZS#-cF7((.smjv.GtAz+.WZd<G544PzG.Mz*Cztr]|Gaw:-(!=');
    /**#@-*/

    /**
    * bbPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $bb_table_prefix = 'bb_';

    /**
    * bbPress Localized Language, defaults to English.
    *
    * Change this to localize bbPress. A corresponding MO file for the chosen
    * language must be installed to a directory called "my-languages" in the root
    * directory of bbPress. For example, install de.mo to "my-languages" and set
    * BB_LANG to 'de' to enable German language support.
    */
    define( 'BB_LANG', 'es_ES' );
    ?>


    chrishajer
    Participant

    @chrishajer

    What happens if you use English instead of Spanish for the language (just remove the es_ES from the BB_LANG setting)? The config file appears to have the proper syntax and that’s the only thing I can see that might be causing a problem.

    OH, also, the languages moved from 0.9 to 1.o.

    0.9: bb-includes/languages/

    1.0 : my-languages/

    I would make sure the language files are in the correct location for 1.0, or just try disabling the language for a minute to see if it works then.


    inerxia
    Member

    @inerxia

    Topic resolved.

    Thanks Mr. Chrishajer


    chrishajer
    Participant

    @chrishajer

    How did you fix the problem, so that others may benefit from your experience?


    inerxia
    Member

    @inerxia

    I did just how you tell me:

    1. Remove the language and every other info that was not in the new bb-config.php

    2. I think the software did not upgrade but install the new version with the old database

    3. Done !

    The latin characters in all the topics went crazy, but Im working on it.

    Thanks again

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.