Skip to:
Content
Pages
Categories
Search
Top
Bottom

Only 5 of my forums are listed! How do I list ALL forums?


  • vladoa
    Member

    @vladoa

    The first 5 forums are displayed on my forums page, but if I add another one, it is not listed, even though it exists and it can be accessed. (I am using bbPress as plugin in WP)

    How do I overcome this limit?

Viewing 13 replies - 1 through 13 (of 13 total)

  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    Are you using a plugin that is being greedy with it’s query filtering?

    The number is limited by the ‘_bbp_forums_per_page’ in the DB, and it’s default value was 15 or 50, depending where it was called.


    MartinM60
    Member

    @martinm60

    I have the same problem.

    Only 5 forums show on the forums page. I found the setting in the bbp-core-options.php file. This is set to 50.

    If I amend to 2, there is no change, still 5 forums displaying.

    Any suggestions to resolve this?


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Are you using a plugin that is being greedy with it’s query filtering?

    Nothing in bbPress core should be limiting it to 5.


    MartinM60
    Member

    @martinm60

    Tried disabling all plugins. Again no change..

    Something seems to be setting a fixed 5 forums display providing there are 5 forums available. Since even if I reduce the setting to less than 5, then nothing changes and the five forums remain on the page.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Are you able to see your DB, or see what ‘_bbp_forums_per_page’ is set to? If you go to Admin > Settings > Form, what are your “per page” settings set to?

    Is there anything anywhere in your WordPress settings where you’ve limited your posts per page to 5?


    MartinM60
    Member

    @martinm60

    Settings are set at 50 in the bbp_forums _per_page. Admin settings are also at 50.

    WordPress settings are not limiting posts.

    What confuses me most is that if I reduce these settings below 5, the displayed forums do not change..

    What is more, there is no ‘next page’ tag to allow users to go beyond the 5 forums which are showing.

    Topics are also limiting at 5., with the forum showing 1-5 of 37 topics, but no means to go beyond the first 5.

    Any suggestions welcome.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Forums don’t have pagination, as generally you wouldn’t want to limit them.

    If topics are also being limited to 5, something else is up. Is it possible the theme you’re using is limiting them? What happens if you switch to bbp-twentyten?


    vladoa
    Member

    @vladoa

    I found out that the theme has a special setting on how many posts should be displayed and that overrides other settings.

    Forums are kept in the same database table as ordinary posts and this is why the theme setting affects the forums as well.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    You should alert the theme author. They should be checking the post_type on the query before filtering it.


    mickh
    Member

    @mickh

    Hello, i’m french boy

    I have installed plugin Forum bbpress in my WordPress website

    and i have created more than 50 Forums, 79 forums

    but i see in my page forum 50 forums ?

    how i can do for to see more than 50 forums ?

    Thanks

    Ok Guys, I had the same problem.

    As John James said, it’s a theme problem

    I my case the value of modest_archivenum_posts = 5 and now =50 :) and that way my trouble is gone.

    I hope you can find your solution

    Adios Amigos

    @darkvander

    I have the same problem too, I use premium theme from elegantthemes.com and after some test and try I found that I need to modify the ‘Number of Posts displayed on Archive pages’ within ePanel theme options.

    So if you use another theme (paid or free) and you encounter the same problem, just may be you need to change any number related to archive pages.

    Hope it helps.


    jamieskella
    Member

    @jamieskella

    Thanks guys – you’re legends. My issue is fixed.

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.