Skip to:
Content
Pages
Categories
Search
Top
Bottom

No avatars show up


  • agitainment
    Member

    @agitainment

    Hi.

    I recently installed bbPress on my WordPress site here at http://agitainment.com/ics/forum/.

    I’ve built a theme based on 1col_fixed 1.1 (I believe it’s kakumei with most of the CSS stripped out). In any case, when I go to my forums I can see my Gravatars and default avatars in kakumei, but when I switch on my theme they disappear.

    Is there a php file I’m missing or a block of code somewhere I need to copy over from the kakumei theme to get these to work? If so, where should I put the code?

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)

  • agitainment
    Member

    @agitainment

    I realize the avatars question has been discussed here before, but I can’t find forum postings that answer this particular question. If you know of one, by all means, please point me in that direction. Thanks.


    chrishajer
    Participant

    @chrishajer

    Avatars are turned on the the admin settings?

    Do you have this in your template’s post.php:

    <?php post_author_avatar_link(); ?>

    Also, this appears in profile.php:

    <?php if ( $avatar = bb_get_avatar( $user->ID ) ) : ?>

    <div id="useravatar"><?php echo $avatar; ?></div>

    <?php unset($avatar); endif; ?>


    agitainment
    Member

    @agitainment

    Thanks, chrishajer! I got it working now.

    Had to change

    <?php post_author_avatar_link(); ?>

    to

    <?php post_author_avatar(); ?>

    but now the avatars are showing in my theme.

    Thanks for the quick response.

    Cheers!

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.