Skip to:
Content
Pages
Categories
Search
Top
Bottom

Moderator Unable To Post To Forum: iPhone iPad


  • Matoca
    Participant

    @matoca

    I don’t use an iPhone or iPad but one of my moderators does. I count on her to keep an eye on this capability for me. Today she wrote me that she can’t post at all on either after an ios update.

    Is anyone able to advise me how to fix this so she can post? If she can’t post, then others who use the website on their iPhones probably can’t post either.
    Thank you,
    Matoca

    Here is her message to me:
    “Today I did an update (ios 7.0.4) to my iPad. NOW, just like my iPhone, I can not post on the forum anymore. Hmmmm……so, now it’s both my iPhone and my iPad, but both AFTER I updated the software. NOW the only way I can communicate (write) on the forum is on my computer. And as I’m rarely home and if so, not often near the computer, I am not able to post often. Hence, I have not been communicating much on the forum – now it will be less until I get this worked out. On both my phone and ipad, I can read all the posts, it updates to the latest and greatest posts, but the keyboard will not come up to write to post.

    I will try to go by the Apple store here to see if they have any answers, but as this just happened today after installing the “update” to my iPad, I did not really realize the problem was related to the updates – now, I’m sure it is. Gotta love Apple!! Or not…”

Viewing 13 replies - 1 through 13 (of 13 total)

  • Matoca
    Participant

    @matoca

    Linda is still unable to post anything from her iPad or iPhone on the forum. I am wondering if anyone has any suggestions on how to work this out so she can post?
    Thank you, Matoca


    Robin W
    Moderator

    @robin-w

    I suspect this is not related, but always worth checking

    Do you have a forums page with shortcode.

    If not another poster did the following with success for a twentyfourteen theme.

    So let me restate what you found to work:

    1. When creating a menu item for forums, do NOT use the automatically available permalink that ends in “/forums/”
    2. Instead, create a page that has the shortcode [bbp-forum-index] in the body. There could also then be other content or links in the body.
    3. Make sure the page you created does NOT have a permalink that ends in “/forums/”. In my case I had a page Title of “Forums”, but I changed the permalink to end with “/allforums/”.

    I suspect that this will not fix for you, but give it a try anyway !


    Matoca
    Participant

    @matoca

    Robin,
    I am not exactly sure what you mean here. I do know what the permalink for the forum is and /forums/ is part of it, but it doesn’t end the permalink. This is the permalink, with the website and forum name made generic for posting purposes:

    http://www.mywebsite.com/forums/forum/ourgroup/

    Is the second “/forum/” the issue? If I change this now, after many months, won’t this mess things up like bookmarks, menu links within the site and google records? There are three forums under /forums/ with different names.

    The topic that the person would like to reply to is this (a topic she started on a desktop):

    http://www.mywebsite.com/forums/topic/needadvice/#post-3735

    To repeat, she was able to start topics and reply to topics in the text field prior to the ios upgrade. I guess I don’t understand how the permalink is conflicting with the display of the keyboard when she wants to enter text in the form on the page.

    I do understand that js probably plays a role in how taps and drags operate on tablets and phones. In this case these are not triggering the code to display a keyboard but I wouldn’t know where to look for that code and determine what the issue is. Is it a general theme function or is specific to bbPress forms?
    my best, matoca


    Robin W
    Moderator

    @robin-w

    I didn’t know what “post on the forum” means – after 30 years in IT support it could mean anything from the battery has run out to a very very specific set of circumstances, and anything in between.

    Therefore it was only an attempt to see if your user had a bigger issue, like she couldn’t get forum access. If you don’t think it will help, and you will know your moderator, then ignore it, I just got it from a google, and given that no-one else had come back, thought it was worth a try.

    It would be worth you seeing if this is a theme or plugin issue.

    Check other plugins

    Check that no other plugins are affecting this.

    Turn off all other plugins apart from bbpress, and see if that fixes the problem. If the problem is resolved, add back one at a time to see which is causing the conflict.

    Check themes

    If plugins are not the cause, then it may be a theme issue. Switch to a default theme, such as twentytwelve, and test.


    Matoca
    Participant

    @matoca

    Robin,
    Yes, I understand. The description “can’t post” is very vague and certainly was not meant to confuse you. In her email copy posted above she finally described that the keyboard is not coming up. This happened to her twice, once after upgrading her ios on her iPhone and then again when she upgraded the ios on her iPad. So I am assuming this is a conflict with the ios release 7.0.4.

    None of the other moderator are having trouble posting so I felt sure it must be something directly related to ios 7.0.4, bbPress and how bbPress signals the device to fill in the topic or reply form correctly. She can navigate the website and read the forum fine.

    I use a google nexus tablet and I sometimes notice idiosyncrasies with scrolling down a forum page. But I am able to get a keyboard when I want to write a reply.

    I have posted to the theme developer as well. Perhaps they will have a better idea of how this conflict is happening.

    Thank you for your help!
    matoca


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    No issues posting from iPhones or iPad’s here, and I use them both quite often on up-to-date versions of iOS.


    Matoca
    Participant

    @matoca

    John,
    This is significant. Are you logged in as administrator when you are posting?

    If this is the case, then it may be a theme problem and not anything to do with bbPress.
    thank you, Matoca


    Robin W
    Moderator

    @robin-w

    Yes, I’d check themes and plugins as above !


    tharsheblows
    Participant

    @tharsheblows

    I had a problem with a user who couldn’t post from her iPad – it was an issue with tinyMCE and I ended up disabling it. Also, someone who used tinyMCE on a different platform had problems as well – he read about her problem on our forum and emailed me with the same issue.

    Here was her initial report – I am not sure if it’s the same problem your user is having:

    there’s something very odd going on with the cursor control when I try to input text using a stylus and the onscreen keyboard of my iPad2. If I touch the screen to move the cursor way from the latest word typed, perhaps to edit a phrase or correct a typing error, then the whole thing seems to freeze. To release it, I have to touch the key that moves the keyboard offscreen and then touch the screen again to place the cursor wherever I need to amend the text – the keyboard reappears, I type in the amendment and then the cursor is fixed at that point again. Every time I want to move around the text in any way, I have to repeat the keyboard-disappearance-and-touch-the-screen-to-place-the-cursor trick.

    It wasn’t a problem across all iOS devices – I never did figure out exactly what combination of things on hers was causing it and I was going to disable tinyMCE anyway, so didn’t try all that hard to figure it out.

    I don’t know what version of tinyMCE WP uses – I see that WP 3.9 is using tinyMCE 4 but not sure if it’s going to be 4.0.11:

    http://stackoverflow.com/questions/18629341/cannot-type-into-empty-tinymce-4-area-on-ipad


    Stephen Edgar
    Moderator

    @netweb

    Conveniently I’m at my parents for dinner…

    This is on an iPad 2iPad 3… And moving the cursor around to edit text works fine…

    Now editing the original post with an iPad 3,iPad Air and still fine.

    So a 2, 3 and 5/Air iPads are working fine to post and/or edit and/or change cursor location.

    With all that said I have also experienced this exact same issue here on bbPress.org using my iPad. As each of these 3 iPads were originally mine and are now my parents yet I can’t reproduce the issue any longer.

    I don’t know what version of tinyMCE WP uses – I see that WP 3.9 is using tinyMCE 4 but not sure if it’s going to be 4.0.11:

    WP 3.9 is currently now using 4.0.21, if 4.0.22 is released before WP 3.9 in ~4 days that might also make it into 3.9.

    https://core.trac.wordpress.org/ticket/24067#comment:152


    Matoca
    Participant

    @matoca

    Update. Last week as soon as I read that there had been trouble with tinyMCE, I disabled the bbPress Enable TinyMCE Visual Tab Version 1.0.1 plugin I had been using. I was using it mainly so moderators could do a bit more in the forum but it wasn’t critical.

    The results were that, -perhaps-, this was part of the problem but it’s not that straightforward. The moderator tried to post using her iPhone and responded:

    “I could put my name in and e-mail address AND it did show up as I typed. But, when I posted, the typing was transparent. I knew it was ‘typing’ because the auto word finish worked and came up. And then when I hit ‘submit’ the post did show up.”

    So then I needed to know if she had tried this while she was logged in or not. I have the forum set for no registration so anyone can post, but I don’t allow them to input html. If she was not logged in then she wouldn’t be able to post in html. I thought perhaps her iPhone or iPad has text attributes set that wouldn’t be allowed.

    So I quizzed her:
    > So the keyboard came up for you this time, no problem? That was the important thing.
    Yes, it came up.
    >
    > So then next, you could see what you were typing in the name and email fields?
    Yes.
    >
    > But then when you were typing in the message window, the text was not visible?
    Right, NOT visible.
    >
    > And finally when you hit submit you could see that you had posted.
    Yes, it was then visible and posted.
    >
    > I can see what you posted and besides the fumbled spelling cause you couldn’t see, it works.
    Right – my fingers on the tiny keyboard are not conducive to proper spelling, punctuation. 😜
    >
    > So I need to know, first are you logged in when you are adding your message?
    No, I’m NOT logged in.

    > Do you see a message that says “Your account has the ability to post unrestricted HTML content.”
    No, i don’t see that.
    >
    > And then when you are at the message window, look at the tabs on the upper right. Were you on the visual tab or the text tab when you were writing?
    Visual, couldn’t get into Text.
    >
    > Try typing another message with the other tab selected. I suspect you were in the visual tab so try the text tab this time.
    Doesn’t work. 😣

    Then a few days later we were back at it again. She tried this logged in.
    “Logged in. Using iPad. This is what I got from ‘Text’

    Hi. This is a test – now is the time for all AIHA/IMHA doggies to be well.

    <strong>bold</strong>

    <em>italics</em>

    And this is what I got in ‘Visual’

    Hi. This is a test.

    Now is the time for all AIHA/IMHA doggies to be well.

    Bold: </strong>

    Italic: <em>

    Then later that day she tried logging out and posting:
    “I logged out and tried to post again to my Sadie:Weaning post. I seemed to have lost a word or two from the post, once I hit submit, but it WAS in sequence and I COULD type AND the typed showed as I typed. This was the first time in months that it’s worked. Yeah!!!!!”

    And yesterday she reported (logged out):
    “Okay – just posted to Joe. First, had to tap hard to get the keyboard to come up. It finally did and I could put in name, e-mail, showing what I wrote. But once I tried to actually post, again, after tapping hard anonymity (“on it?”)five times, the cursor would move with each letter I hit, but I could not see shat (see what?) I was writing.”

    WP just updated to 3.8.3 (without my input…) so would that have some version of tinyMCE in it? I thought that they had removed it completely a while back and at that time I lost the text tab in the forum when posting as a moderator. So that is when I installed the tinyMCE plugin.

    I wish I could say that this seems resolved, but it seems that she is still having erratic behavior from the keyboard when she is trying to enter text either logged in or not logged in. It is significant that she can get the keyboard to come up at all, that was not happening before.

    I am trying to make sure my site is responsive and is usable by most phones and tablets. On my Google Nexus I have a bit of trouble scrolling down the page, it’s erratic and resistive. But that may have more to do with the page loading slower over wifi.

    I hope this thread stays open so there can be further input?
    thank you, matoca

    WP just updated to 3.8.3 (without my input…) so would that have some version of tinyMCE in it?

    No, it is the same TinyMCE version that shipped with WordPress 3.8, the new TinyMCE v4 is included in WordPress 3.9 and should be available within the next 24 hours.

    This topic can indeed stay open and if you could post an update after you have updated to WordPress 3.9 that would be helpful.

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.