Skip to:
Content
Pages
Categories
Search
Top
Bottom

Link markup (URLs) being stripped


  • Arlo
    Member

    @arlo

    I’m having an odd problem with posts. Hyperlinks are being stripped.

    This: <a href="http://foo.com">foo</a>

    Is being stripped down to: <a>foo</a>

    Any ideas? I’m running latest svn build, the .8.1 patch plugin, and a few other plugins.

Viewing 8 replies - 1 through 8 (of 8 total)

  • chrishajer
    Participant

    @chrishajer

    Member baptiste here had a similar problem although it was with 0.75:

    http://bbpress.org/forums/topic/641

    Maybe your issue is similar?


    fel64
    Member

    @fel64

    Are you using a plugin which adds to the usable tags? Disable it and see if the problem still occurs.

    Also check if the links are in the database and are just being filtered out, or if they’re properly removed.


    Arlo
    Member

    @arlo

    Thanks for the responses.

    1) The link is stripped in the database. I had tested the “img” tag plugin, but disabled it because it didn’t work (it was actually having the same problem, stripping out the src="").

    2) I looked over baptiste’s thread. I guess it’s the same thing, but sadly there’s no solution there. I’m using a WP include as well.

    I don’t know if this is relevant, but I also had the stripslashes problem as well. That was fixed with a template hack. Is there a hack to fix this? It’s pretty much a show stopper…


    Trent Adams
    Member

    @trent

    Why are you including WP in your example? Is is just styling or something else?

    Trent


    Arlo
    Member

    @arlo

    This is the site: http://automatorworld.com/bbpress/

    I’m wrapping my whole WP site around bbpress. It’s more than just styling, as you can see. I though this wasn’t supposed to present problems, but I guess this whole “kses” thing is one, eh?


    Arlo
    Member

    @arlo

    Re-reading the baptiste thread, I see that commenting out add_filter('pre_post', 'bb_filter_kses', 50); in default-filters does the trick. It solves all my problems at once!

    I guess bbpress needs to do better conflict checking againt wp when wp is included.


    eddd54
    Member

    @eddd54

    Hi,

    i’m having the same problem with my WordPress and bbPress integrated install – (href tags getting stripped and extra slashes getting added)

    See here: http://bbpress.org/forums/topic/641 and here: http://bbpress.org/forums/topic/670

    I’m running:

    WordPress 2.1.3

    bbPress 1.0-alpha

    The 2 fixes worked for me but rather than editing the bb-includes/default-filters.php file.. i put the temporary fixes in a quick bbPress Plugin so that i don’t end up forgetting about the modifications after an upgrade and can now easily deactivate the plugin should this issue get permenantly resolved.

    I put the plugin up online. If you’re interested, you can download it here: http://indyish.googlepages.com/fix-href-slashes.php

    Thanks – the plugin was really useful.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.