Skip to:
Content
Pages
Categories
Search
Top
Bottom

Getting “already installed error” on fresh install

  • Hi,

    I am running a WP site and trying to install BBpress, but when I run the install.php file, I keep getting the “already installed” error.

    Here are some things I’ve already tried:

    I created a new test directory and installed a fresh WP out of box, and then tried installing BB press–same error

    I checked my databases–the only two I have are my two Word Press DB’s none of which seem to have any “bb_” references to them.

    Any other suggestions? Thanks in advanced!

    Here is a copy of my config.php file that I am using in my test directory:

    <?php

    // ** MySQL settings ** //

    define(‘BBDB_NAME’, ‘areamomc_wrdp2′); // The name of the database

    define(‘BBDB_USER’, ‘areamomc_wrdp2′); // Your MySQL username

    define(‘BBDB_PASSWORD’, ‘**************’); // …and password

    define(‘BBDB_HOST’, ‘localhost’); // 99% chance you won’t need to change these last few

    define(‘BBDB_CHARSET’, ‘utf8′); // If you are *upgrading*, and your old config.php does

    define(‘BBDB_COLLATE’, ”); // not have these two contstants in them, DO NOT define them

    // If you are installing for the first time, leave them here

    // Change the prefix if you want to have multiple forums in a single database.

    $bb_table_prefix = ‘bb_'; // Only letters, numbers and underscores please!

    // The full URL of your bbPress install

    $bb->uri = ‘http://www.areamom.com/test';

    // What are you going to call me?

    $bb->name = ‘Area Mom Forums';

    // This must be set before you run the install script.

    $bb->admin_email = ‘*********';

    // Set to true if you want pretty permalinks, set to ‘slugs’ if you want to use slug based pretty permalinks.

    $bb->mod_rewrite = false

    // The number of topics that show on each page.

    $bb->page_topics = 30;

    // A user can edit a post for this many minutes after submitting.

    $bb->edit_lock = 60;

    // Your timezone offset. Example: -7 for Pacific Daylight Time.

    $bb->gmt_offset = -5;

    // Change this to localize bbPress. A corresponding MO file for the

    // chosen language must be installed to bb-includes/languages.

    // For example, install de.mo to bb-includes/languages and set BBLANG to ‘de’

    // to enable German language support.

    define(‘BBLANG’, ”);

    // Your Akismet Key. You do not need a key to run bbPress, but if you want to take advantage

    // of Akismet’s powerful spam blocking, you’ll need one. You can get an Akismet key at

    // http://wordpress.com/api-keys/

    $bb->akismet_key = ‘********'; // Example: ‘0123456789ab’

    // The rest is only useful if you are integrating bbPress with WordPress.

    // If you’re not, just leave it as it is.

    $bb->wp_table_prefix = ‘wp_'; // WordPress table prefix. Example: ‘wp_';

    $bb->wp_home = ‘http://www.areamom.com/test'; // WordPress – Options->General: Blog address (URL) // Example: ‘http://example.com’

    $bb->wp_siteurl = ‘http://www.areamom.com/test'; // WordPress – Options->General: WordPress address (URL) // Example: ‘http://example.com’

    /* Stop editing */

    if ( !defined(‘BBPATH’) )

    define(‘BBPATH’, dirname(__FILE__) . ‘/’ );

    require_once( BBPATH . ‘bb-settings.php’ );

    require_once(‘/public_html/test/wp-blog-header.php’)

    ?>

Viewing 2 replies - 1 through 2 (of 2 total)

  • chrishajer
    Participant

    @chrishajer

    I didn’t think you could put bbPress and WordPress in the same folder.

    $bb->uri = ‘http://www.areamom.com/test';

    $bb->wp_home = ‘http://www.areamom.com/test';

    $bb->wp_siteurl = ‘http://www.areamom.com/test';

    And http://areamom.com/test/ points to a WordPress installation. So, where’s the bbPress? I did find this:

    http://areamom.com/test/bbpress/ which results in this error:

    Parse error: syntax error, unexpected T_VARIABLE in /home/areamomc/public_html/test/bbpress/config.php on line 29

    That’s right after the mod_rewrite line in the config. Maybe you have an extra single quote there or you forgot the semi-colon in your config? Oh yeah, check this:

    $bb->mod_rewrite = false <– no semi-colon.

    That means this you should add the semicolon to the mod_rewrite line line and then this line should be changed:

    `$bb->uri = ‘http://www.areamom.com/test/bbpress';

    you rock! thanks!

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.