Skip to:
Content
Pages
Categories
Search
Top
Bottom

Get "Cheatin’ uh?" When Trying To Save Forum Settings


  • lkicknosway
    Participant

    @lkicknosway

    I just installed bbPress on my site. I wanted to change the setting from disallow editing after 5 minutes to 10 minutes but when I click save changes I get a “Cheatin’ uh?” Page. Even if I don’t change anything and click save changes I still get the “Cheatin’ uh?” page. Why is this and how can I get it to save my changes?

    I installed bbPress version 2.5.3 and my WordPress version is 3.8.1. I’ve also installed W3 Total Cache Plugin. I have disabled minify of HTML & XML but have JS minify enabled and CSS.

    Thanks in advance.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Seems like the bbPress user role ‘keymaster’ is trying to make you have a bad day.

    Open up bbPress’ Repair Tools from the Dashboard -> Tools -> bbPress (/wp-admin/tools.php?page=bbp-repair)

    Run the Repair Tool “Remap existing users to default forum roles”

    How’d did that go?


    lkicknosway
    Participant

    @lkicknosway

    That did the trick! I ran the repair tool just as you suggested. Then logged out, went and had a coffee. When I got back and logged in again, I was good to go. :-)

    Cheers.


    Robin W
    Moderator

    @robin-w

    That coffee always helps !

    Glad you’re fixed !


    jesseaaron
    Participant

    @jesseaaron

    Sorry to bump this, I’m having same “Cheatin’ Uh” error but the “remap existing users to default forum roles” did not work for me. The results were “0 users modified”. Any other ideas?


    Robin W
    Moderator

    @robin-w

    @jesseaaron

    Original poster got this as a result og “I just installed bbPress on my site. I wanted to change the setting from disallow editing after 5 minutes to 10 minutes but when I click save changes I get a “Cheatin’ uh?” Page”

    Can you explain what you were doing, and if you did as per @lkicknosway
    and logged out and back in again !


    jesseaaron
    Participant

    @jesseaaron

    Sure thing. I recently installed bbpress and wanted to adjust the Single Forum Slugs to a different name so the URL isn’t /forums/forum/. When I tried to save I go the Cheatin Page.
    I’ve also recently installed myCred and have been making tiny CSS adjustments to the bbpress classes (just colors and font size & weights).


    Robin W
    Moderator

    @robin-w

    thanks. So are you back to the forums/forum and only getting this problem each time you try and change that field? In other words that’s the only time you’re getting it?


    jesseaaron
    Participant

    @jesseaaron

    No I just noticed the url was /forums/forum so I wanted to change it to be less redundant. It appears that way for everyone (i.e.; http://www.mashbout.com/forums/forum/hangout/)


    jesseaaron
    Participant

    @jesseaaron

    Srry again for bump – it seems anything I try to change in the Forums Settings (Dashboard > Settings > Forums) results in the Cheatin’ Page when I try to save.


    Robin W
    Moderator

    @robin-w

    sorry I wasn’t being clear.

    but you answer does throw up a fix, you can take out the display of that out either by changing the “show forum prefix” in settings>forums, or changing what is displayed :

    http://codex.bbpress.org/layout-and-functionality-examples-you-can-use/#4-turning-off-or-changing-breadcrumbs

    On you original Q :

    1. Do you still have this problem if you try that change
    2. are you getting the ‘cheating’ problem anywhere else


    jesseaaron
    Participant

    @jesseaaron

    Everything I do in Settings>Forums gives me the Cheatin’ Page. I tried logging out, waiting, logging back in, and doing the same thing while deleting cache too. Still getting the Cheatin error.

    Try creating a new user and giving them the WordPress ‘Administrator’ role and bbPress role ‘keymaster’ log out and log in with this new user and see what happens.


    jesseaaron
    Participant

    @jesseaaron

    Same thing happened; anything I try to change in Forum Settings gives me then Cheatin Uh page when I try to save.

    Have you tried disabling ALL your plugins and switching to the Twenty Thirteen theme?

    Once you disabled the above check to see if the issues still occurs.

    If it still occurs now with all that disabled try creating a new user again and check if that new ‘keymaster’ user works as expected.

    Now start by re-enabling your theme, still working?

    Now re-enable one pllugin, does it still work?

    Now enable another plugin, still work?

    You see a pattern here? Enable another plugin, still work?

    I have a sneaking suspicion your using a ‘User Role’ or ‘Membership’ plugin and this is causing you an issue.

Viewing 14 replies - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.