Skip to:
Content
Pages
Categories
Search
Top
Bottom

Email notification not working


  • Martyn Chamberlin
    Participant

    @martyn-chamberlin

    Hi folks,

    I’m using BBPress over at raisingharmony.com/forums/. It is a premium content area, meaning you can’t access the forum without proper login credentials. I would be happy to provide some if it would assist in troubleshooting. My trouble is that when people checkmark the checkbox that says, “Notify me of follow-up replies via email,” they aren’t getting the email.

    Couple of notes:

    (1) I’m using WordPress 3.4.2.
    (2) I’m using BBPress 2.1.2.
    (3) The PHP mail() function works just fine on the rest of the site.
    (4) My only modification to the plugin is that in the /wp-content/plugins/forums/bb-includes/bbp-common-functions.php file, I’ve updated the bbp_check_for_floodI() function to return “True” every time, but this shouldn’t be affecting the email functionality in any way.

    Just googling around and looking on this forum, it looks like other people have complained about this 13 months ago, but nobody ever posted an answer other than, “Cool, it’s working now.”

    Any suggestions?

    Thanks!
    Martyn Chamberlin

Viewing 7 replies - 1 through 7 (of 7 total)

  • Lynq
    Participant

    @lynq

    Hey,

    I had an issue with this and wrote a small plugin which seemed to of resolved it.

    http://pastebin.com/ADfuRHiH

    Not sure if it is still an issue but before adding this plugin it did not always work (it did sometimes) and after it seems to work all the time, it can still go into spam though.

    Good luck!


    Martyn Chamberlin
    Participant

    @martyn-chamberlin

    Hi Lynq,

    Bummer! I activated your little plugin, but this didn’t do the trick. Still not getting email notifications.

    I’m thinking the problem must be specific to BBPress since the primary WP emails are going out just fine.

    Any other suggestions?


    nightshift58
    Participant

    @nightshift58

    When a reply is stored and “Notify me…” is checked, the subscription request is not stored in wp_usermeta.

    As such, subsequent queries to retrieve the subscribers yield none.

    If I manually add a record in wp_usermeta, the notification is then sent as expected.

    Best,
    Bob
    iMember360.com


    Martyn Chamberlin
    Participant

    @martyn-chamberlin

    Oh my goodness. That’s crazy! Sounds like a serious error on the part of BBPress.

    What do you suggest we do about this?


    nightshift58
    Participant

    @nightshift58

    In includes/replies/functions.php, bbp_udate_reply() is not receiving $author_id.

    Subsequently, the call to bbp_get_current_id() is failing (whereas wp_get_current_user(), when added, is not failing).

    Considering that we’re on v2.2.2, it’s strange to see such basic errors creep up.

    Best,
    Bob
    iMember360.com


    nightshift58
    Participant

    @nightshift58

    I’ve added a filter to iMember360 so that the correct $author_id is returned.

    Best,
    Bob
    iMember360.com


    jeffredbeardconsulting
    Participant

    @jeffredbeardconsulting

    I’m having the same failure of the “Notify me of follow-up replies via email” box. When I reply to a post and check the “Notify me of follow-up replies via email” box and reply to the post I get no email. However, if I go back and select “Edit” for my post and re-check the “Notify me of follow-up replies via email” box then all replies to the post result in an email to me. Why is the initial input box not responding? I am using bbPress 2.5.2.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.