Skip to:
Content
Pages
Categories
Search
Top
Bottom

Deep Integration whitepage / Fatal error: require_once() Solution


  • simple_gpr
    Member

    @simple_gpr

    To add to the list of potential solutions to the Fatal errors for require_once people are encountering whilst completing deep integration of BBpress into WordPress.

    If in your error log something similar to this:

    PHP Fatal error: require_once() [function.require]: Failed opening required ‘/var/www/vhost<domain>/httpdocs/wp-load.php’ (include_path=’.:’) in /var/www/vhost/<domain>/forum/httpdocs/bb-config.php on line

    16

    and you have tried using absolute paths instead of relative paths and the other various solutions people have suggested don’t work. Then you will need to change your php.ini file and add the directory for your wordpress installation to the open_basedir variable.

    i.e. open_basedir = /var/www/vhost/<domain>/httpdocs

    The other option is to turn off open_basedir altogether.

    If you are on a sharedhost and do not have access to php.ini your webhost will have a vhost.conf or similar file which will allow you to send directives to Apache for your particular domain. In this case you will need to have this within your vhost.conf file.

    <Directory “/var/www/vhosts/<domain>/forum/httpdocs”>

    php_admin_value open_basedir “/var/www/vhosts/<domain>/httpdocs:/tmp”

    php_admin_value include_path “.:”

    </Directory>

    I hope this helps those having issues with deep integration whitepages / require_once fatal errors and saves people some time.

You must be logged in to reply to this topic.