Skip to:
Content
Pages
Categories
Search
Top
Bottom

“column forum_slug can’t have a default value” error with installation


  • sjons
    Member

    @sjons

    Hope this is the right place. I just installed the latest svn version on my local pc, and got the forementioned error twice (also with topic_slug field). Running mysql 5.0.

    Patch:

    Index: upgrade-schema.php
    ===================================================================
    --- upgrade-schema.php (revision 805)
    +++ upgrade-schema.php (working copy)
    @@ -4,7 +4,7 @@
    $bb_queries = "CREATE TABLE $bbdb->forums (
    forum_id int(10) NOT NULL auto_increment,
    forum_name varchar(150) NOT NULL default '',
    - forum_slug text NOT NULL default '',
    + forum_slug text NOT NULL,
    forum_desc text NOT NULL,
    forum_parent int(10) NOT NULL default '0',
    forum_order int(10) NOT NULL default '0',
    @@ -31,7 +31,7 @@
    CREATE TABLE $bbdb->topics (
    topic_id bigint(20) NOT NULL auto_increment,
    topic_title varchar(100) NOT NULL default '',
    - topic_slug text NOT NULL default '',
    + topic_slug text NOT NULL,
    topic_poster bigint(20) NOT NULL default '0',
    topic_poster_name varchar(40) NOT NULL default 'Anonymous',
    topic_last_poster bigint(20) NOT NULL default '0',

    Regards,

Viewing 1 replies (of 1 total)

  • Sam Bauers
    Participant

    @sambauers

    Can you create a ticket for this here. You can login with the same user/pass you use on this forum.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.