Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbPress 2.0.2 plugin pretty permalinks 404

  • I have spent countless hours trying to solves this but im still having no luck. I have trawled through google and the bbpress forum but can’t seem to find a solution.

    While updating a website for a client they asked for buddpress to be removed as no one was using the social network side of the site, and a stand alone forum be put in place, hence bbpress.

    I started off by removing the buddypress plugin and all it files, deleted the bb-config.php and dropped all the tables in the database with the prefix wp_bp.

    I installed the latest bbpress plugin from within the wordpress admin and activated it, then created a few test forums and topics.

    The forum displays fine when the default permalink structure is used however when I turn pretty permalinks on all the pages go to a 404 page not found.

    I have tried adding Options +Multiview and Options -Multiview to the .htaccess. I have tried setting the bbpress mod_rewrite to true and false but still no luck.

    I have also tried chmod 777 the .htaccess file.

    Here is my .htaccess file:

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    # BEGIN ANTISPAMBLOG REGISTRATION

    RewriteCond %{REQUEST_METHOD} POST

    RewriteCond %{REQUEST_URI} .join-hello*

    RewriteCond %{HTTP_REFERER} !.*helloecoliving.com.* [OR]

    RewriteCond %{HTTP_USER_AGENT} ^$

    RewriteRule (.*) http://helloecoliving.com/spam-prevention [R=301,L]

    # END ANTISPAMBLOG REGISTRATION

    #uploaded files

    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*

    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin

    RewriteCond %{REQUEST_URI} ^.*/wp-admin$

    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule . – [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]

    RewriteRule . index.php [L]

    </IfModule>

    <IfModule mod_security.c>

    <Files async-upload.php>

    SecFilterEngine Off

    SecFilterScanPOST Off

    </Files>

    </IfModule>

    <Files 403.shtml>

    order allow,deny

    allow from all

    </Files>

    deny from 93.182.137.19

    This is driving me crazy all my other custom post types work!

    Any help is appreciated!

Viewing 2 replies - 1 through 2 (of 2 total)

  • Sniper Kitten
    Member

    @sniperkitten

    Did you change the forums base? (By default it’s “forums”)

    Can you show me your website’s URL?

    Yeah I have tried the default forums and tried changing it to discussions then flushing the htaccess file but it still 404′s it works when the default wordpress permalink settings are used.

    The site is helloecoliving.com (the clients host is very slow)

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.