Skip to:
Content
Pages
Categories
Search
Top
Bottom

404 Errors on Forums/Topics


  • chengdu living
    Participant

    @chengdu-living

    bbPress is installed in this directory: http://www.chengduliving.com/bbpress (using a customized theme to match my site, http://www.chengduliving.com) but none of the threads or forums open. They all show a 404 error. Originally I was installed at /forum but I moved it to /bbpress (and changed the install location in General Settings), but I can’t open or create any threads.

    Any idea how to fix this? I didn’t change anything in bb-config.php so I believe all the MySQL information is correct.

    Any help greatly appreciated!!

Viewing 2 replies - 1 through 2 (of 2 total)

  • chengdu living
    Participant

    @chengdu-living

    BTW I tried what was advised in this thread: http://bbpress.org/forums/topic/bbpress-broke-when-i-changed-the-url but it just displayed the code on the actual live forum page

    Here is my bb-config.php included the added part at the very bottom:

    <?php
    /**
    * The base configurations of bbPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys and bbPress Language. You can get the MySQL settings from your
    * web host.
    *
    * This file is used by the installer during installation.
    *
    * @package bbPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for bbPress */
    define( 'BBDB_NAME', 'justchar_wrdp5' );

    /** MySQL database username */
    define( 'BBDB_USER', 'justchar_wrdp5' );

    /** MySQL database password */
    define( 'PASSWORDWASHERE' );

    /** MySQL hostname */
    define( 'BBDB_HOST', 'localhost' );

    /** Database Charset to use in creating database tables. */
    define( 'BBDB_CHARSET', 'utf8' );

    /** The Database Collate type. Don't change this if in doubt. */
    define( 'BBDB_COLLATE', '' );

    /**#@+
    * Authentication Unique Keys.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/bbpress/ WordPress.org secret-key service}
    *
    * @since 1.0
    */
    define( 'BB_AUTH_KEY', 'put your unique phrase here' );
    define( 'BB_SECURE_AUTH_KEY', 'put your unique phrase here' );
    define( 'BB_LOGGED_IN_KEY', 'put your unique phrase here' );
    define( 'BB_NONCE_KEY', 'put your unique phrase here' );
    /**#@-*/

    /**
    * bbPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $bb_table_prefix = 'bb_';

    /**
    * bbPress Localized Language, defaults to English.
    *
    * Change this to localize bbPress. A corresponding MO file for the chosen
    * language must be installed to a directory called "my-languages" in the root
    * directory of bbPress. For example, install de.mo to "my-languages" and set
    * BB_LANG to 'de' to enable German language support.
    */
    define( 'BB_LANG', '' );
    ?>

    $bb->uri = 'http://www.chengduliving.com/bbpress/';


    chengdu living
    Participant

    @chengdu-living

    I found the solution! I went under Settings > Permalinks and updates the .htaccess file with the information there.

    If this happens to anyone in the future, check there :)

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.