Skip to:
Content
Pages
Categories
Search
Top
Bottom

Pretty Permalinks Not Working


  • laemo
    Member

    @laemo

    Hello,

    I have read the FAQ here: http://bbpress.org/documentation/faq/#pretty-permalinks

    and I have tried both, using Options +MultiViews and also using the code generated by /bb-admin/rewrite-rules.php but I cannot seem to get my permalinks working.

    http://www.nmimsieee.com/forums/ is the link to my forums.

    I am using GoDaddy for hosting. I have set $bb->mod_rewrite = true in my config.php and my forums are in the same database as WordPress.

    I recently migrated my forums to my WordPress database, and I did the same at home (I have a server running on my laptop, and I just loaded all the data onto the domain mentioned above).

    Permalinks work fine at home on my WAMP setup. However on my domain at GoDaddy, I get an error saying “No input file specified.”

    Could anyone please help me out and tell me where am I going wrong? I would really appreciate it.

Viewing 51 replies (of 51 total)

  • minervaa
    Participant

    @minervaa

    I had the same problem with pretty permalink.

    Background:

    Main site = http://www.site.com

    Blog = http://www.site.com/blog (WP 2.8)

    Forum = http://www.site.com/forum (bbPress 0.9.06)

    I installed the blog few weeks ago and didn’t touch apart of posting a “hello world”. Wp gave me a message on that time to enter this on root htaccess –

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /blog/

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /blog/index.php [L]

    </IfModule>

    I must mention that the htaccess had already

    Options +FollowSymLinks

    RewriteEngine on

    Then I installed the forum today. After activating the name based permalink it gave me 404 message. I deleted the “+FollowSymLinks” from the htaccess and put –

    Options +Multiviews

    It worked fine for few hours but it started showing 404 again. After going through various posts in here I decided not to change the Multiviews as my hosting already mod_rewrite enabled.

    I made another htaccess just for the forum,which look like this –

    Options +FollowSymLinks

    RewriteEngine on

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /forum/

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /forum/index.php [L]

    </IfModule>

    The pretty permalink is working at the moment. Hopefully it will be working in future too.

Viewing 51 replies (of 51 total)
  • You must be logged in to reply to this topic.