Skip to:

DB Error: cannot select

  • InvTrdr


    When I get past Step1 I keep getting this message that will not allow me to proceed to Step2. Any help? I am using GoDaddy for hosting and followed all the instructions. Am not using the same database as WP is using. Have created a new one for bbPress.

Viewing 3 replies - 1 through 3 (of 3 total)

  • InvTrdr


    Below is the content of my config.php file. I have X out the important details.



    * The base configurations of bbPress.


    * This file has the following configurations: MySQL settings, Table Prefix,

    * Secret Keys and bbPress Language. You can get the MySQL settings from your

    * web host.


    * This file is used by the installer during installation.


    * @package bbPress


    // ** MySQL settings – You can get this info from your web host ** //

    /** The name of the database for bbPress */

    define( ‘BBDB_NAME’, ‘bbPress’ );

    /** MySQL database username */

    define( ‘BBDB_USER’, ‘XXXXXXXX’ );

    /** MySQL database password */

    define( ‘BBDB_PASSWORD’, ‘XXXXXXXX’ );

    /** MySQL hostname */

    define( ‘BBDB_HOST’, ‘’ );

    /** Database Charset to use in creating database tables. */

    define( ‘BBDB_CHARSET’, ‘utf8’ );

    /** The Database Collate type. Don’t change this if in doubt. */

    define( ‘BBDB_COLLATE’, ” );


    * Authentication Unique Keys.


    * Change these to different unique phrases!

    * You can generate these using the {@link secret-key service}


    * @since 1.0


    define( ‘BB_AUTH_KEY’, ‘Vj-3}{i=juL$9u<4CG3S.V[XXXXXXX(]JYa>}b1PyZ$/s-|fs6b1b^HXXXXX186:’ );

    define( ‘BB_SECURE_AUTH_KEY’, ‘;/ML=-Xx(}/:J@VNr.$|zXXXXXXXX)B>dGTr+3NETTQAQ/ S&T4e}{,&OOjA|bxj’ );

    define( ‘BB_LOGGED_IN_KEY’, ‘V4L?XXXXXXXX$|#9E2`72+&?kMq(n~[3p54XzX+L|7r-6 w0{N-,QiWn[;Y$FUtN’ );

    define( ‘BB_NONCE_KEY’, ‘c]rdQ[|fn$_S}z~RVX5fR6~Rg$0XXXXXXXX}6{$vDxC>WS~4/+Ft+Ea.|4:3l>JU’ );



    * bbPress Database Table prefix.


    * You can have multiple installations in one database if you give each a unique

    * prefix. Only numbers, letters, and underscores please!


    $bb_table_prefix = ‘bb_’;


    * bbPress Localized Language, defaults to English.


    * Change this to localize bbPress. A corresponding MO file for the chosen

    * language must be installed to a directory called “my-languages” in the root

    * directory of bbPress. For example, install to “my-languages” and set

    * BB_LANG to ‘de’ to enable German language support.


    define( ‘BB_LANG’, ” );




    *what* is the error message you’re receiving?



    The error message was “DB Error: cannot find”. Figured out that for some reason the database name filled in during step1 was not caught by the bbpress-config.php file as you can see in the code above. The BBDB_NAME has been left “bbpress” as in default. Changed it in the file and it worked. Now onto Step2.


Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar