Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can't get link to forum page from my wesite.


  • oneshortleg
    Participant

    @oneshortleg

    I installed bbpress on my wordpress site. It is a new site, I have no other plugins installed. It still have the default 2012 theme.

    I can access the forum menus from the dashboard, and I’ve created a few forums. If I click “view” in the list of forums from the dashboard, I can see them.

    However, when I go to see my web page, there is no option on the navigation menu for the forums. There is just “Home”, “Blog”, and one other page I already created.

    How is one visiting the site supposed to find the forums?

    I tried Simple Press briefly and it just created it’s own page and a menu link. I also tried Mingle, and for that I needed to create a page on the navigation menu for it before I did the install. What do I need to do for bbpress?

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)

  • Stephen Edgar
    Moderator

    @netweb

    Open your WordPress admin dashboard and got to ‘Appearence’ -> ‘Menus’ (/wp-admin/nav-menus.php)

    Add a link eg http://example.com/forums your menu and click save.


    oneshortleg
    Participant

    @oneshortleg

    I’m not seeing that option on the Appearance > Menu section. There is no place to add a link. The only fill-able field is the name for creating a new menu. I tried creating one called “forums”, and added the forums to it, but it does not show up in the page menu at the top of the site.

    Do I need to create a page for the forums first?

    Perhaps I am not being clear about what I’m trying to do. I want there to be a link to the Forums page in the tabs that show up at the top of the page (I think this is called the “page menu?).

    Thanks


    Stephen Edgar
    Moderator

    @netweb

    Here are some step by step instructions for what I mentioned above that hopefully will be a little clearer and the link you add would be http://example.com/forums where you replace example.com with your domain name.

    https://codex.wordpress.org/Appearance_Menus_Screen#Custom_Links


    oneshortleg
    Participant

    @oneshortleg

    Thanks, I finally got it! One question, though….

    According to what you told me, my forum page should be located at http://example.com/forums

    This did not work (I get a 404 error). Instead, it is http://example.com/?post_type=forum. I used this for the url in the custom menu, and it works.

    Is this going to be a problem down the road?

    I don’t know why it matters, but this is a typical WP install using an ftp client (uploaded WP from my computer to the server and did the quick install). As an experiment today, I used the simple-script feature from Bluehost (my host) to do a test WP install in another location. I installed bbpress on it and the forums page is where you said it would be (http://example.com/forums).

    Any idea why my forums are at this other address?

    Thanks


    Stephen Edgar
    Moderator

    @netweb

    Its your permalinks settings…. Check out how to set ‘pretty permalinks’ here: https://codex.wordpress.org/Using_Permalinks


    oneshortleg
    Participant

    @oneshortleg

    Thanks, that was it! I changed the Permalink setting to day+name, and it all looks the way it should.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.