Skip to:

Re: New installation



How do you ensure? Well, you can look at your wp-config.php and see what the table prefix is there. If you didn’t change it, it’s wp_. bbPress uses bb_ by default. If you don’t change either of them, they will go properly into separate tables in the same database.

There is something simple going wrong with the connection details. It really is as simple as the username, database name, password and host. I think they call the host “advanced database settings” in the installation. If you click that, I think it unhides the table prefix setting and the host setting. I always have to change the host in my installations, so to me that’s not an advanced setting. WordPress recently changed the terminology of that (it used to say something like “99% chance you won’t need to change this”) to something like “get these details from your host.” Maybe you just need to enter the host setting and you are not seeing where to do that.

I’m guessing it’s the host setting you’re not entering, since it’s not visible on the installation screen. If it’s different that localhost in your wp-config.php, my guess is that’s the problem. You need to set that for bbPress.

Skip to toolbar