Skip to:
Content
Pages
Categories
Search
Top
Bottom

WP3.51 (Multisite) + Buddypress (1.6.4) + bbPress (2.2.4) = Hell


  • RemotePCSupport
    Participant

    @remotepcsupport

    Situation:

    Have a WP (3.5.1) installed and multi site enabled to use sub domains only (no top level domain mapping)

    1. Create 1st Sub Site sub1.mysite.com and assign it to a new user (tom)
    2. In another browser (Firefox) i login as tom to wp-admin and am able to got to the dashboard of sub1.mysite.com
    3. Create a 2nd Sub Site sub2.mysite.com and assign it to user Tom
    4. I switch back to firefox and f5 (refresh page) I can see in the top admin bar that Tom now has 2 subsites…and i can navigate to the dashboard of both sites…

    I then proceed to install buddypress and activate it at the primary site (mysite.com – not network activated) as per tutorial @ http://labzip.com/the-definitive-guide-to-buddypress-bbpress-configuration/

    After which i repeat steps 1 thru 4 above to make sure i can still create and access subsites as the user Tom… and yes I can… We’re goo to here

    Then I install bbpress following the same tutorial on the above video…

    Now that I have a installation that comprises of WP3.5.1 Multisite configuration + Buddy Press + bbPress… I test once more…

    So i proceed to perform the same steps 1 thru 4 above.. but this time with different results..

    If i create the subsites via superadmin and try to login as user Tom.. I’m able to..

    But if i go to front end of site using another browser (Firefox) i am able to login using my user and pass as Tom. But when i add an additional blog under Toms user account.. the blog gets created..

    I then refresh the page and logout as Tom and the log back in as Tom i can see the admin bar has the new site listed under my sites. But when i go to mouse over the newly self created site the only two options i see are dashboard and visit site.

    If i click dashboard i get a blank page with the error message “You do not have sufficient permissions to access this page.”

    If i deactivate bbPress and then try to access the same sub site i still get “You do not have sufficient permissions to access this page.”

    However if i register another sub site as Tom i can access the dashboard for this newly created subsites (Site created after deactivation of bbPress)

    Reading blog’s and forums..

    It appears to be an issue with roles and capabilities of a self generated sub site when bbPress is activated…

    I have now spent 2+ days messing around with this and these is little documentation here at bbPress site..

    In fact the documentation is available here…: http://bbpress.org/about/multisite/ and is useless as its not done…

    There seems to be a million install guides that all show how to activate and configure bbPress..

    Am i the only one with this issue as no one seems to be speaking about this anywhere that i have read…

    “NOW PULLING MY HAIR OUT”

    HELP!!! Anyone.. Someone..

Viewing 4 replies - 1 through 4 (of 4 total)

  • kaarinalisa
    Participant

    @kaarinalisa

    I also have the similar issues that I cannot deactivate the bbpress plugin. If I do, I lose the admin dashboard and get the login/change error “You do not have sufficient permissions to access this page.”

    I have not used multi-site option, merely installed the plugin to begin to evaluate for use on my site.

    The only thing we have been able to figure out to do is to leave the plugin activated. But that is not a long term solution.

    Please advise how I can deactivate the plugin without breaking my site admin capabilities.

    Try using FTP to delete the plugin directly from /wp-content/plugins/bbpress/

    (I would make sure you have a backup first of your hosts files and your WP database)


    nitroblood
    Participant

    @nitroblood

    I’m having the same installation, ie. WP3.51 (Multisite on subdomain) + Buddypress (1.6.4) + bbPress (2.2.4), and is facing the exact same problem with RemotePCSupport. Users who created their sub sites when bbpress is ACTIVATED, are denied access to the admin dashboard of the same sub sites they created! No issue for those who created their sub sites when bbpress is DEACTIVATED though.

    This issue has to be solved! What’s the point of having a multisite setup when users DO NOT have access to the sites they created??

    Also, these warnings are shown whenever users create new sub site blogs,

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/domain/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Nevertheless, the sites are created successfully, but it sure looks ugly to show these warnings!

    @nitroblood This is fixed for 2.3 (details here)

    You can download bbPress 2.3 beta 2 from here if you want to confirm it fixes your issues.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.