Skip to:
Content
Pages
Categories
Search
Top
Bottom

Where is the importer?

  • I read that bbPress 2.0-beta1 comes with an importer for bbPress 1.0.

    Where can I find it?

Viewing 25 replies - 1 through 25 (of 30 total)

  • Mark Barnes
    Member

    @mark-barnes

    Tools/Import :)


    Mark Barnes
    Member

    @mark-barnes

    Tools/Import :)

    Thanks. :)

    Should mention that somewhere in the installation instructions.

    Thanks. :)

    Should mention that somewhere in the installation instructions.

    De-activated all other plugins and switched to the twentyten theme.

    When trying to import, I got:

    Fatal error: Cannot redeclare class BPDB in /home/cristi/git/lomo/forum/bb-includes/backpress/class.bpdb.php on line 39

    The standalone version of bbPress is 1.1-alpha.

    De-activated all other plugins and switched to the twentyten theme.

    When trying to import, I got:

    Fatal error: Cannot redeclare class BPDB in /home/cristi/git/lomo/forum/bb-includes/backpress/class.bpdb.php on line 39

    The standalone version of bbPress is 1.1-alpha.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Are you already using deep integration of some kind? I imagine we should wrap things in _exists checks just incase, and bypass the bb-config.php check if so.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Are you already using deep integration of some kind? I imagine we should wrap things in _exists checks just incase, and bypass the bb-config.php check if so.

    I’m using standard integration. Even disabled all other plugins and switched to twentyten.

    Maybe my alpha version isn’t alpha enough…

    I’m using standard integration. Even disabled all other plugins and switched to twentyten.

    Maybe my alpha version isn’t alpha enough…

    I got a 500 server error the first time I ran the importer. Is ‘continuing’ the process recommended or should I start over?

    (Pressing continue a second time resulted in Firefox trying to server me admin.php as a download)

    edit: doing it on localhost works a lot smoother!

    I got a 500 server error the first time I ran the importer. Is ‘continuing’ the process recommended or should I start over?

    (Pressing continue a second time resulted in Firefox trying to server me admin.php as a download)

    edit: doing it on localhost works a lot smoother!


    Gautam Gupta
    Moderator

    @gautamgupta

    kai920: Right. The 500 internal server error happened because the server couldn’t handle the load. :)


    Gautam Gupta
    Moderator

    @gautamgupta

    kai920: Right. The 500 internal server error happened because the server couldn’t handle the load. :)

    I managed to get past the fatal error by adding these two lines in my bp-config.php file:

    define('BB_DATABASE_CLASS', 'BPDB');
    define('BB_DATABASE_CLASS_INCLUDE', false);

    Now I’m getting more errors:

    Warning: Missing argument 2 for BPDB::__construct(), called in .../forum-svn/bb-settings.php on line 197 and defined in .../lomo-content/plugins/bbpress/bbp-admin/importers/bbpress.php on line 29

    Warning: Missing argument 3 for BPDB::__construct(), called in .../forum-svn/bb-settings.php on line 197 and defined in .../lomo-content/plugins/bbpress/bbp-admin/importers/bbpress.php on line 29

    Warning: Missing argument 4 for BPDB::__construct(), called in .../forum-svn/bb-settings.php on line 197 and defined in .../lomo-content/plugins/bbpress/bbp-admin/importers/bbpress.php on line 29

    Fatal error: Cannot redeclare bb_cache_users() (previously declared in .../lomo-content/plugins/bbpress/bbp-admin/importers/bbpress.php:103) in .../forum-svn/bb-includes/functions.bb-users.php on line 39

    This is using bbPress plugin 2.0-beta-2b and bbPress standalone trunk.

    I managed to get past the fatal error by adding these two lines in my bp-config.php file:

    define('BB_DATABASE_CLASS', 'BPDB');
    define('BB_DATABASE_CLASS_INCLUDE', false);

    Now I’m getting more errors:

    Warning: Missing argument 2 for BPDB::__construct(), called in .../forum-svn/bb-settings.php on line 197 and defined in .../lomo-content/plugins/bbpress/bbp-admin/importers/bbpress.php on line 29

    Warning: Missing argument 3 for BPDB::__construct(), called in .../forum-svn/bb-settings.php on line 197 and defined in .../lomo-content/plugins/bbpress/bbp-admin/importers/bbpress.php on line 29

    Warning: Missing argument 4 for BPDB::__construct(), called in .../forum-svn/bb-settings.php on line 197 and defined in .../lomo-content/plugins/bbpress/bbp-admin/importers/bbpress.php on line 29

    Fatal error: Cannot redeclare bb_cache_users() (previously declared in .../lomo-content/plugins/bbpress/bbp-admin/importers/bbpress.php:103) in .../forum-svn/bb-includes/functions.bb-users.php on line 39

    This is using bbPress plugin 2.0-beta-2b and bbPress standalone trunk.

    After importing the users I’m getting a warning that no administrator rights have been assigned to any user and I need to do so myself. I have to log in again but the passwords don’t work as also stated in the warning.

    My first question is: why do the passwords not work?

    Second: I get a hint to edit the database myself, but how to do so when dealing with encryption?

    After importing the users I’m getting a warning that no administrator rights have been assigned to any user and I need to do so myself. I have to log in again but the passwords don’t work as also stated in the warning.

    My first question is: why do the passwords not work?

    Second: I get a hint to edit the database myself, but how to do so when dealing with encryption?

    Found out it’s got something to do with my earlier conversion from phpbb to bbpress standalone. But it still got me confused:

    All the logins work perfectly after the first conversion (phpbb > bbpress 1.0), but after conversion from 1.0 to 2.0 all the logins block. Only accounts newly created in 1.0 get through in 2.0.

    In the database there’s a visible difference between logins from phpbb (start with $H$7) and bbpress 1.0 (start with $P$9). Since there is no login error in bbpress 1.0 I don’t think it’s a problem with the phpbb conversion (used this converter recommended somewhere on this forum).

    Can someone give me a hint on how to solve this?

    Found out it’s got something to do with my earlier conversion from phpbb to bbpress standalone. But it still got me confused:

    All the logins work perfectly after the first conversion (phpbb > bbpress 1.0), but after conversion from 1.0 to 2.0 all the logins block. Only accounts newly created in 1.0 get through in 2.0.

    In the database there’s a visible difference between logins from phpbb (start with $H$7) and bbpress 1.0 (start with $P$9). Since there is no login error in bbpress 1.0 I don’t think it’s a problem with the phpbb conversion (used this converter recommended somewhere on this forum).

    Can someone give me a hint on how to solve this?


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Most likely you’re one of the first people trying to do this, so it’s doubtful anyone has specific tips.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Most likely you’re one of the first people trying to do this, so it’s doubtful anyone has specific tips.

    bb-config.php doesn’t exist in my bbpress 2.0 version, what do i do, have nothing to proceed

    bb-config.php doesn’t exist in my bbpress 2.0 version, what do i do, have nothing to proceed


    Andre
    Participant

    @andrejcarter

    @harry.mat – What are you trying to do? bb-config.php is only used in bbPress versions 0.x and 1.x.

Viewing 25 replies - 1 through 25 (of 30 total)

You must be logged in to reply to this topic.