Skip to:
Content
Pages
Categories
Search
Top
Bottom

What version to use for a new project?

  • Hello,

    Next days (or weeks) I sill start a new project. It will take long to develop and probably it will be finished later this year. I think it will 6 months or a bit more. It must be integrated with the latest version of WordPress.

    So, I’m thinking about starting the project with the 1.0 alpha versions. I know it’s not as stable or secure as 0.9.x but hope it will be later this year. I’ve seen there are lots of changes from 0.9 to 1.0 and perhaps will be easiest to merge the new 1.0 versions than 0.9 to 1.0…

    What’s your opinion? It’s the best idea to start the project with the alpha version ? Or you would start it with 0.9x and in the future you will make all arrangements to upgrade it? Consider that it will be finished this year fall.

    Thanks for your comments,

    Txanny.

Viewing 8 replies - 1 through 8 (of 8 total)

  • chrishajer
    Participant

    @chrishajer

    I would use 1.0 alpha if it were me.


    kevinjohngallagher
    Member

    @kevinjohngallagher

    Txanny, it’s hard to say as you’re talking about 6 months down the line, but if it was me i’d leave BBpress until the end of your development cycle. We’ve no idea what the 1.0 alpha is going to look like in 6 months, as the next release is going to break 2/3 of all plugins and none are being updated for some time, and _ck_ herself has stated she’s not fixing any of hers until 1.1 .

    Given that 1.0alpha came out in September 16th last year and isn’t anywhere close to being out of alpha just now (some 6 months later), I’d suggest not making a decision on which BBpress version for quite some time yet, at least until 1.0alpha7 and we can see what the plugin fall out is.

    If it was me though, i’d go with 0.9. it works well, the plugins work, development on it can continue, and it’s stable.


    johnhiler
    Member

    @johnhiler

    I agree, I’d stick with v 0.9 for now. Too many plugins don’t work on 1.0, and even if they did… some of them will probably break with the various alpha point releases.

    Thanks all for your responses and comments. After evaluating it, I agree with chrisjager and I think the 1.0 alpha is the best option. Mostly because probably I will use only a part of bbpress in this project, and not the entire program. Of course it will be a GPL licensed project.


    _ck_
    Participant

    @_ck_

    No do not start with 1.0 unless you plan to not use any plugins.

    You can always upgrade from 0.9 to 1.0

    You can *never* downgrade from 1.0 to 0.9 because of the dramatic db changes involving tags and meta.

    Even if you are “only using part of bbPress” (not sure what that means) 1.0a6 is about to do a semi-radical change with 1.0a7 involving permalinks.

    bbPress 0.9 templates will (mostly) work with 1.0 but not visa versa.

    1.0 is about 150% the code size than 0.9 for the same functionality.

    I could go on but the point is that 1.0 is changing and unstable by nature. It should not even be called alpha but pre-alpha.


    Ashfame
    Participant

    @ashfame

    @ _ck_

    I am also going to use bbPress alpha for a live site. I don’t want to use any plugins. Just what bbPress is offering at the moment is required (more functionality is not a pain though). Should I go for it as I have tested with WP 2.7 for login syncs (partly – the way i want with my custom user panels). Would like to know your opinion. Thanks!

    I tested both.

    1.0-alpha integrates better but is more unstable and there are lots of errors. I would no use it on a live site.

    0.9.0.4 is much stable, and runs fine. I used this plugin http://bbpress.org/plugins/topic/freshly-baked-cookies/ and then forced always to login/logout from WordPress. That works perfect. Login/out from bbPress does not run correctly in this situation, so I preferred to force to login/logout from wordpress.

    In my case I was talking for a project 6-9 months vista, to be finished later this year. This makes things a bit different as I hope then bbPress 1.0 will be more mature.

    Also consider that you always can upgrade from 0.9 to 1.0… but you can NOT to downgrade from 1.0 to 0.9. So, perhaps I would start from the stable version.

    Regards,

    Txanny.


    Ashfame
    Participant

    @ashfame

    @Txanny

    Thanks for the feedback. I think I will start with the stable release only.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.