Skip to:
Content
Pages
Categories
Search
Top
Bottom

User profile pages not working (apart from for first administrator)


  • michaelnobbs
    Member

    @michaelnobbs

    I’ve installed bbPress 2.0.1 and integrated it with the s2Member plugin.

    All seems to be working in the forum apart from when users click on their (or any other) profile links. They receive a page not found.

    The profile link does work, however, for my profile (the site administrator). I can view my profile and so can other members.

    I’ve tried creating a second administrator to see if the profile link would work then. It doesn’t.

    Has anyone else come across this issue?

    With thanks for any help or suggestions.

Viewing 11 replies - 1 through 11 (of 11 total)

  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    Another user here has a similar issue. Check the user_nicename column in your database. It should include a sanitized version of the user_login. If instead it has spaces or illegal characters in it, that’s the culprit.


    michaelnobbs
    Member

    @michaelnobbs

    Thank you for replying so quickly, John.

    I’ve checked the database and all the username appear fine, all lowercase characters, no spaces or illegal characters that I can see.


    michaelnobbs
    Member

    @michaelnobbs

    When I say username, I do mean the user_nicename.

    same here…

    as posted to the other topic, i get the “error404″ class in response body of the profilpage(non edit)

    the edit does not work(except for networkadmins), on click edit i get 404

    in detail:

    URL: http://domain.com/?bbp_user=15&edit=1

    Method: GET

    Status: 302 Found

    URL: http://domain.com/?bbp_user=15

    Method: GET

    Status: 404 Not Found

    im using my own them for bbpress(add_theme_support( ‘bbpress’ );)

    thanks in advance…

    mga2

    (to carolcody)

    i forgot to mention, the user name should work…

    user_login: anderer

    display_name: anderer

    user_nicename: anderer

    no spaces, lower-case only…

    as mentioned, i also tried the following: used superadmin and clicked edit… copied the get url, logged in as non super admin and tryed the altered url…

    http://domain.com/?bbp_user=15&edit=1

    so there is no nicename involved…

    im using a multisite installation of wordpress… by super admin, the network administrator was meant

    today made a fresh install of wordpress 3.2.1 and bbpress 2.0.2, all default settings…

    i created only a forum with one topic… the userprofile(and edit) does not work…

    on non multisite wordpress everything worked as expected…..

    what information should i provide to help investigation?


    mrraine
    Member

    @mrraine

    exactly the same for me, its driving me crazy and i have put already alot of time into getting bbpress going.

    Bbpress is definatly the best looking wp forum but damn its doing my head in!

    After spending some hours with the same strange behaviour i finally found a solution:

    This error happens when you’r running WP in a multisite-environment, only on the mainsite AND if you added define('NOBLOGREDIRECT', 'http://example.com'); to your wp-config.php

    Adding remove_action( 'template_redirect', 'maybe_redirect_404' ); to your themes functions.php will stop that annoying bug.

    I guess this error happens because maybe_redirect_404() is fired before the profile-pages are build. the network administrator (or sub-sites) will be never redirected by NOBLOGREDIRECT, thats why the bug never happends when a network-admin clicks on a profile-link or when you’r running bbpress on a sub-site in your WP-network.

    More about the NOBLOGREDIRECT-fix (it also helps showing 404-errors): http://frumph.net/2010/06/05/wordpress-3-0-multisite-subdomain-installation-noblogredirect-behavior-fix/

    • This reply was modified 1 year, 8 months ago by  Fuchsy.

    mcla345pau
    Member

    @mcla345pau

    This was kind of complicated to follow at first but I was just able to figure this out after several hours. Sorry still noob.


    thoughtbludgeon
    Member

    @thoughtbludgeon

    I tried your solution Fuchsy, but it did not work for me, user pages are still 404.

    Any suggestions?

    Try any user aside from admin:http://www.tbgamers.com


    Steveorevo
    Participant

    @steveorevo

    I found this issue was related to my Host’s Nginx settings. Turning off “custom/own error documents” resolved the issue (not sure why).

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.