Skip to:
Content
Pages
Categories
Search
Top
Bottom

"User Not Found" Error

  • Hi – I recently set up a forum, integrated with WordPress.

    bbPress 1.02

    WP 2.7

    Everything is working fine, but several users are reporting that when they click the “View Profile” link they get a “User Not Found” error. I have examined their accounts in the database and have not found anything to differentiate them from other users.

    I did find a thread on this forum referring to a similar error for the Key Master after setup. The solution there was to manually add a user nice name in the database. My problem is different as all users have nice names defined in the database already.

    Any help would be greatly appreciated!

    Thanks!

Viewing 1 replies (of 1 total)
  • Hi, there! I had this error, too, and I think I might know what it is. You mentioned that all users already have nicenames. What link structure are you using? Try switching permalinks to “None” (the default) and seeing if the profiles work. If they do, then that means that you need to manually edit your users’ nicenames in the WordPress database. The nicenames must match the display usernames of the users.

    An alternative solution is to use 301 redirects in your .htaccess to redirect profile links. The profiles of those users whose profiles are broken actually do exist. Try replacing the part of the URL that contains their username with their user_nicename. You may find that they exist, so you can do redirection if you’re afraid of messing with the mySQL. This is definitely the inferior solution, though. Editing the nicenames in the mySQL shouldn’t cause problems.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.