Skip to:
Content
Pages
Categories
Search
Top
Bottom

URL in email is incorrect

Viewing 6 replies - 1 through 6 (of 6 total)

  • Stephen Edgar
    Moderator

    @netweb

    This could be an issue with your rewrite rules. To fix this try resetting your permalinks. In your WordPress Administration Screens navigate to Settings > Permalinks, select a different permalink structure and save. Then select your preferred permalink structure and save again.


    SickSquirrelTwo
    Participant

    @sicksquirreltwo

    Thanks. Was Post Name, changed, saved, now it’s back. Says to update .htaccess.

    Main directory .htaccess below. Not sure what to update. I just know it would be a little easier but I also like things to work right. One error leads to two, etc

    <IfModule mod_rewrite.c>
    ##BLOCKWP attacks
    RewriteEngine on
    RewriteCond %{REQUEST_METHOD} =POST
    RewriteCond %{HTTP_REFERER} !^http://(.*)?.sitenamehidden.com [NC]
    RewriteCond %{REQUEST_URI} ^/wp-login\.php(.*)$ [OR]
    RewriteCond %{REQUEST_URI} ^/wp-admin$
    RewriteRule ^(.*)$ – [R=403,L]
    </IfModule>

    #
    # Uncomment the statement below if you want to make use of
    # HTTP authentication and it does not already work.
    # This could be required if you are for example using PHP via Apache CGI.
    #
    #<IfModule mod_rewrite.c>
    #RewriteEngine on
    #RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
    #</IfModule>

    <Files “config.php”>
    Order Allow,Deny
    Deny from All
    </Files>

    <Files “common.php”>
    Order Allow,Deny
    Deny from All
    </Files>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress


    SickSquirrelTwo
    Participant

    @sicksquirreltwo

    The plot thickens. I got email at a different email address with notification of the new post BUT the URL was right.

    It ended with

    You are receiving this email because you subscribed to a forum topic.

    Login and visit the topic to unsubscribe from these emails.

    So email to approve is wrong but subscribed posts email is correct.

    Y’all know which email is generated and how so y’all will know what’s wrong.


    Stephen Edgar
    Moderator

    @netweb

    WordPress should be able to automatically update your .htacess file which it looks like it is based on the last ~11 lines of your post above. Those first ~9 lines though could be the problem as it looks like they are from another WordPress plugin or added by your webhost.

    http://codex.wordpress.org/Using_Permalinks#Automatically_updating_.htaccess

    If you don’t know what plugin is adding the extra bits to your .htaccess file try disabling all of your plugins except bbPress, go back to your WordPress permalinks settings and update the settings again which forces WordPress to update your .htaccess file and see how that goes.


    Stephen Edgar
    Moderator

    @netweb

    If any of the emails need to link to either wp-login.php or /wp-admin then based on these two lines from your .htaccess file ‘something’ will happen ;) I am not familiar enough with .htaccess and mod_rewrite to know this stuff of the top of my head ;)

    RewriteCond %{REQUEST_URI} ^/wp-login\.php(.*)$ [OR]
    RewriteCond %{REQUEST_URI} ^/wp-admin$

    SickSquirrelTwo
    Participant

    @sicksquirreltwo

    I created the file and it is dated 7/11 so nothing is writing to it, I created it based on a recommendation at a security website or wordpress.org (forget which). I have an .htaccess.old file I’ll paste below.

    The email removes the forums/topics/etc, which are set in WordPress under Settings/Forums/Slugs Obviously I don’t remember coding but y’all know where the email picks up the actual post URL. Somehow it is stripping the Slugs. But just in Approval emails … so what differs between Approval and Subscribed emails in pulling the URL? I think that would be the place to start to find the error/problem/issue/annoyance.

    (I go to Dashboard and look for a number next to Replies and Posts, so I DO have a way around the email discrepancy. I just like to fix things like this before it causes more errors/problems/issues/annoyances).

    .htaccess.old (I didn’t compare them side by side to see if anything differs. I know if I FTP a file already there it adds.old to the old file)

    #
    # Uncomment the statement below if you want to make use of
    # HTTP authentication and it does not already work.
    # This could be required if you are for example using PHP via Apache CGI.
    #
    #<IfModule mod_rewrite.c>
    #RewriteEngine on
    #RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
    #</IfModule>

    <Files “config.php”>
    Order Allow,Deny
    Deny from All
    </Files>

    <Files “common.php”>
    Order Allow,Deny
    Deny from All
    </Files>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.