Skip to:
Content
Pages
Categories
Search
Top
Bottom

Upgrading to 2.8 break the SSO


  • greatpatton
    Member

    @greatpatton

    I have today in production a bb-press Version 1.0-alpha-5 (I’m not moving to RC1 as recommanded by _ck_) and WP 2.7. The SSO between the 2 was working perfectly.

    I just upgraded my WP install to the new version 2.8, and now whatever I try the SSO is broken (if I log in WP, I’m disconnected from BBpress, and vice-versa). The wp-config.php and bb-config.php are in synch.

    Is it a known problem?

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yes. And it’s mentioned all over :)

    Try removing define('WP_AUTH_COOKIE_VERSION', 1); from your bb-config.php file.


    greatpatton
    Member

    @greatpatton

    Thanks but there is no such paramater in the bb-config.php of Version 1.0-alpha-5….

    I think that if this problem has no solution it will be great to post a warning here!

    There should have been (that param was required for 2.7/1.0 integration).

    Check your bbAuth keys in bb_config and make sure they match the WP ones. Flush your cache and cookies. Your browser could be caching the old cookies, as they did change in WP 2.8.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.