Skip to:
Content
Pages
Categories
Search
Top
Bottom

Upgrade Path Suggestions

  • I am currently running the following:

    WP 2.3x (using due to theme limitations)

    BBPress 0.8.3.1

    I am planning to upgrade the theme to be compatible with the latest version of WordPress. Once I do this I need to upgrade BBpress. Given the availabiltiy of the Alpha and the 2.5 restriction of BBpress 0.9 I was looking for suggestions on how to go about things.

    Option 1 – Is this a valid path?

    1. Upgrade to WP2.5 & BBpress 0.9

    2. Wait for stable 1.0 Beta of BBpress

    3. Upgrade to WP 2.6x and BBpress 1.0

    Option 2

    1. Upgrade to WP2.6 & BBpress Alpha

    Questions:

    1. Is a 2.5 version of WP still being distributed?

    I hope this was clear. Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)

  • chrishajer
    Participant

    @chrishajer

    Option 1 is valid. When bbPress comes out later though, WordPress might be higher than 2.6. There might always be a little bit of lag between versions for compatibility, but the idea is sane: upgrade now, then wait for a new version and upgrade again later.

    Option 2 is also valid.

    Question 1: yes, you can grab any old release from WordPress.org:

    http://wordpress.org/download/release-archive/

    Also, you need only worry about compatibility if you are looking for integration. Other than that, the versions don’t need to be sync’d up.

    And finally, you need to be careful running old versions to be certain there were no security fixes. The move from 2.6 to 2.6.1 had nothing to do with security, but the move from 2.5 to 2.6 did. So I guess 2.5 had some security issues. [citation needed]

    Thanks. I do need integration.

    I may set up a dev.domain.com area and get things up and running first. I have never done this but it would seem to be the safest path.

    schmitt – I’m curious to learn how things went & what you ultimately decided to do. I’m in the process of asking the same ‘approach’ questions for my 2.5.1 / 0.8 website that has ‘basic’ integration.

    Which option did you choose, and how did you implement?

    Any lessons learned are appreciated.

    rgds

    bforeste

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.