Skip to:
Content
Pages
Categories
Search
Top
Bottom

Upgrade advice needed.

  • I have several wordpress blogs and have upgraded all but one to 2.7

    I still have one using 2.5.1 to upgrade, which has bbpress 0.9.0.2

    linked to it. When will I be able to upgrade, as I’m aware that 2.5.1 has apparently some security issues.

    If I upgrade the blog now will I lose he forum, any help greatly Appreciated.

    Thanks. Mike.

Viewing 4 replies - 1 through 4 (of 4 total)

  • chrishajer
    Participant

    @chrishajer

    What are the security issues you are concerned with in 2.5.1?

    There is no date I know of for releasing bbPress 1.0, and there has been an alpha release almost weekly, which means it’s a moving target as new things get addressed in every alpha release.

    Hi again, and thanks for the reply, I visit the wordpress forums a lot and have only heard that 2.5.1 is insecure, have no reason why though, its always been very good while I’ve been using it. I’m just trying to keep up with develpements before I upgrade this blog to 2.7, and hope fully my bbpress 0.9.0.2 forum will still work.

    all the best.

    mike.


    chrishajer
    Participant

    @chrishajer

    In general I try to keep up with WordPress releases as well. The upgrade from 2.5.1 to 2.6 included these bug fixes:

    http://trac.wordpress.org/query?status=closed&milestone=2.6

    In 2.5.1 the AUTH keys thing was really sorted out, so they changed that in 2.6 and that’s the main reason 2.6 is not compatible with the 0.9.* branch of bbPress.

    If you don’t require integrated logins between the forum and the blog, then you don’t have to upgrade your bbPress to use the latest WordPress. If you do need integrated logins, then you probably need to wait for the 1.0 branch of bbPress to upgrade WordPress to the latest.


    chrishajer
    Participant

    @chrishajer

    Also, if you do attempt to upgrade either bbPress or WordPress, be sure to make a backup (database and filesystem.)

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.