Skip to:
Content
Pages
Categories
Search
Top
Bottom

updating 0.8.3.1 to bbpress-1.0.2 with Wampserver


  • flowiesowieso
    Member

    @flowiesowieso

    Hello,

    I’m using bbpress 0.8.3.1 at my site. Since there is a 1.0 release I’ve been wanting to update my bbpress. But to make sure everything works fine I tried the update on my localhost with Wampserver. Once I follow the install instructions I’ve been asked to create a new bb-config. Filling in the 4 steps gives me an error saying:

    Installation errors

    Forums already exist!

    Key master email not sent!

    Installation log

    Referrer is OK, beginning installation…

    Step 1 – Creating database tables

    >>> Database is already installed!!!

    Step 2 – WordPress integration (optional)

    >>> Integration not enabled

    Step 3 – Site settings

    >>> Site name: forum

    >>> Site address (URL): http://localhost/forum/

    >>> From email address: myadres@gmail.com

    >>> Key master created

    >>>>>> Username: admin

    >>>>>> Email address: myadres@gmail.com

    >>>>>> Password:

    >>> There are existing forums in this database.

    >>>>>> No new forum created.

    >>> Key master email not sent!

    There were some errors encountered during installation!

    If I go to http://localhost/forum it says;

    Deprecated: Assigning the return value of new by reference is deprecated in I:wampwwwforumbb-settings.php on line 186

    Deprecated: Assigning the return value of new by reference is deprecated in I:wampwwwforumbb-includesbackpressfunctions.wp-object-cache.php on line 108

    Deprecated: Assigning the return value of new by reference is deprecated in I:wampwwwforumbb-includesbackpresspomomo.php on line 171

    Deprecated: Assigning the return value of new by reference is deprecated in I:wampwwwforumbb-includesfunctions.bb-l10n.php on line 484

    Could not determine site URI

    I’ve no idea were to resolve this problem. Can someone point me in the right direction? I’m quite scared to do this for my live verion of the forum. Or shouldn’t I and is the problem probably with trying it on my localhost with Wampserver?

Viewing 3 replies - 1 through 3 (of 3 total)

  • Gautam
    Member

    @gautam-gupta

    Which PHP version are you using?


    kevinjohngallagher
    Member

    @kevinjohngallagher

    Hi flowiesowieso,

    Deprecated errors:

    This is a common error with WAMP runing PHP 5.3.

    You should go to the WAMP homepage > addons > PHP > 5.2.x (latest one)

    Download, Install and then next time you start WAMP, you can click the menu-bar option (bottom right of the screen) and change the PHP version it’s running.

    This issue has been fixed for the next release of bbPress, so it’s only a small issue.

    Cannot determine:

    This is an upgrade issue.

    The easiest way is to head into phpmyadmin and look through your meta table and see if you see anything weird or blank. I know that’s kind of vague (sorry), but there’s a good chance you’ll see your URL slightly wrong in one of the fields (no http, or no localhost or something).

    let us know what you find.


    Ashfame
    Participant

    @ashfame

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.