Skip to:
Content
Pages
Categories
Search
Top
Bottom

Unexpected anonymous posts

  • So, I’m installing and testing my new forum, these days.

    I have 3 users registered for now: 1 is me as Key Master, the other 2 are me again :-) with fake identities just for testing purposes.

    Anonymous posting is (or should, how to check?) be forbitten, for obvious reasons.

    Now, if I go to this thread http://www.kirpi.it/r/topic/scatola I see that an anonymous unregistered poster seems to have contributed to the forum.

    How it such a behaviour explained and how it is avoided, please?

    Note: the post was actually made by me. I personally posted the image and the IP address is definitely the one from which I was working. But I did I manage to post anonymously?

Viewing 5 replies - 1 through 5 (of 5 total)

  • _ck_
    Participant

    @_ck_

    If a user is deleted (or somehow corrupted) the post will show as anonymous.

    Also the post data might be corrupted in some way.

    You’d have to look at the poster_id and see if it matches any user id #

    The users admin table (1) does not seem to show any number. Where am I supposed to check those data, please?

    More generally, is it that likely that a new forum gets so easily corrupted?

    If so, what about an already running forum? Isn’t it a threat?

    —-

    (1) /bb-admin/users.php

    After a few days, the “error” repeated: I posted a couple of things which, later, showed as “anonymous”. See here http://www.kirpi.it/r/

    What could it be done to prevent this, please?

    What should I check?

    Could there be any flaw to look for/after, please?

    I admit that such a behaviour scares me a bit :-|

    Is it a Mysql problem?

    Or is it supposed to be more related to bbpress itself, please?

    Since when I disabled “Enhanced Registration” plugin, new users are not deleted anymore.

    This seems to solve the critical matter.

    It remains to be understood (by me at least) why “Enhanced Registration” deletes new users who have just contributed to the forum. Anyway, the main problem seems solved.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.