Skip to:
Content
Pages
Categories
Search
Top
Bottom

Unable to view old posts


  • frasermassey
    Member

    @frasermassey

    Hi

    I run a WP site and BBpress forum. Recently upgraded to BBpress latest release version and now when I log in I cannot view any old posts and when I try to create a new topic is reports ‘This topic has been closed’

    On the top of dashboard I get the following…

    Warning: Division by zero in D:inetpubvhostssunstridercats.orghttpdocsbbpressbb-includesfunctions.bb-statistics.php on line 214

    Warning: Division by zero in D:inetpubvhostssunstridercats.orghttpdocsbbpressbb-includesfunctions.bb-statistics.php on line 194

    Warning: Division by zero in D:inetpubvhostssunstridercats.orghttpdocsbbpressbb-includesfunctions.bb-statistics.php on line 174

    Warning: Division by zero in D:inetpubvhostssunstridercats.orghttpdocsbbpressbb-includesfunctions.bb-statistics.php on line 244

    I know this warning is shown if it belives there are no posts but the forum has been fine for a long time and has showing on the overview of the dashboard..

    39 forums

    82 topics

    457 posts

    So the posts are still there although I cannot see them or add to them.

    Any help would be greatly appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)

  • frasermassey
    Member

    @frasermassey

    By the way, have tried switching to the default theme which made no difference.

    deactivate your statistics plugin and then try.


    johnhiler
    Member

    @johnhiler

    There was the exact same error messages reported here:

    http://bbpress.org/forums/topic/admin-panel-warning

    Here was the solution:

    It turned out that couple of topics in the topic tables didnt have topic start time.

    It was 0000-00-00 00:00:00. It was probably from converting from phpBB.

    I changed to start times and then there is no warnings anymore.

    Do you have phpmyadmin? You could check the topic start times in the database maybe…


    frasermassey
    Member

    @frasermassey

    Dont have a statistics plugin as far as I know, checked the plugin directory and cannot see it.

    Thanks Johnhiler, I saw that post previous and have checked and they do have start times. I was hoping it was that also :)

    keep suggestions coming please.


    frasermassey
    Member

    @frasermassey

    Just restored all of my BB tables via phpmyadmin to a backup I took last week and ‘seems’ to be working again.

    I suspect it was the WP integration plugin which broke it.

    Will update if problem returns.

    This is what I can think of… The new config files for either bb&wp is different in some way. Or you need to just recount everything under the bbpress admin section.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.