Skip to:
Content
Pages
Categories
Search
Top
Bottom

Unable to login to 2.6 WordPress once logging into bbPress 1.0 Alpha

  • I’ve fixed my particular problem. So this is more or less to point out what the problem is so anyone else having the problem can fix it as well.

    Once I installed 1.0 Alpha and logged into it, I was unabled to login to my wordpress site. The only way I was able to log back into my wordpress site was by deleting all the cookies for my domain (had to repeat this each time I logged into my bbPress site).

    I believe the problem was due to me installing 1.0 Alpha over an 0.9.0.2 install that had wordpress integration already enabled (0.9.0.2 of course wasn’t working since I had also already upgraded to wordpress 2.6). Once I installed 1.0 Alpha, the *_salt values between wordpress and bbPress did not match.

    After some cookie juggling to get logged into my wordpress site so I could see it’s *_salt values, then logging into my bbPress site (in another tab), I was able to set the correct *_salt values, delete my cookies once more, and log into my wordpress site. At this point the integration is working again and my bbPress site recognizes that I’m already logged in.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Might have spoken too soon. That at least fixes the login integration and being able to login to my wordpress site, but now, while I show as logged into my bbPress site, I cannot access the Admin section.

    And it looks like the fix to that is to logout and sign back in through the bbPress site (instead of your wordpress site). Once you do that, wordpress recognizes you are logged in and you can access the Admin section of both sites.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.