Skip to:
Content
Pages
Categories
Search
Top
Bottom

Trying to Convert Mingle to bbpress


  • wolverineguy7575
    Participant

    @wolverineguy7575

    Hello,
    I’m trying to do the convert from mingle to bbpress. I found the post

    http://bbpress.org/forums/topic/importing-mingle-forums-into-bbpress/

    Which Stephen Edgar was assisting someone on and was able to get it to work. I put in the information to start the convert and got this error:

    Repair any missing information: Continue
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\"wp_forums_\"forum_forums AS forum_forums LIMIT 0, 100' at line 1]

    SELECT convert(forum_forums.id USING “utf8″) AS id,convert(forum_forums.parent_id USING “utf8″) AS parent_id,convert(forum_forums.name USING “utf8″) AS name,convert(forum_forums.description USING “utf8″) AS description,convert(forum_forums.sort USING “utf8″) AS sort FROM \”wp_forums_\”forum_forums AS forum_forums LIMIT 0, 100No forums to convertStarting Conversion

    I’m not a database expert by any means and I don’t want to screw up anything. If anyone could help me with getting this done I would appreciate it very much. Mingle is slowing down my site and I need to get to something better.

    Thank you,
    Scott

Viewing 5 replies - 1 through 5 (of 5 total)
  • It looks like you used wp_forums_\ as the table prefix on the importer settings, as a quick guess I think it should be wp_

    Edit: You can confirm what this value should be by opening the wp-config.php file in the root of the WordPress install that has Mingle forums installed.

    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';

    wolverineguy7575
    Participant

    @wolverineguy7575

    Hello Stephen,
    Thank you so much for replying. I opened the wp-config.php and looked up the $table_prefix and it was ‘wp_’ so I tried to run the convert/import and it came up with this message:

    Starting ConversionRepair any missing information: Continue
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\"wp_\"forum_forums AS forum_forums LIMIT 0, 100' at line 1]
    SELECT convert(forum_forums.id USING “utf8″) AS id,convert(forum_forums.parent_id USING “utf8″) AS parent_id,convert(forum_forums.name USING “utf8″) AS name,convert(forum_forums.description USING “utf8″) AS description,convert(forum_forums.sort USING “utf8″) AS sort FROM \”wp_\”forum_forums AS forum_forums LIMIT 0, 100No forums to convert

    I’m really not sure what to do here. Like I said I’m a SQL newbie so I really don’t understand much about it yet.

    Thank you for your assistance so far,
    Scott

    Did you use single or double quotes around wp_?

    The error you show above showing the error as \”wp_\”forum_forums is an odd one, if things were working correctly I would expect the error to look more like this wp_forum_forums.

    Open up your wp-config.php file again:

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'database_name_here');
    
    /** MySQL database username */
    define('DB_USER', 'username_here');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'password_here');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    Make sure the values above are the ones you are using on the bbPress import settings and that you select Mingle as the import type.

    If you still have the same issue you might have to have a chat with your web host to see if there is some extra SQL settings needed by them.


    wolverineguy7575
    Participant

    @wolverineguy7575

    Hi Stephen,
    I tried it with both single and double quotes.

    I opened the wp-config.php and copied the information directly from there. Still getting a similar issue. I’m going to contact bluehost and see what they have to say.

    Thank you for all your assistance. Once I hear from bluehost I will update this thread with that information.

    Scott

    DO NOT USE ANY QUOTES, just use wp_

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.