Skip to:
Content
Pages
Categories
Search
Top
Bottom

Topics Freshness


  • JuanISar
    Participant

    @juanisar

    speaking of Freshness…. I just imported my website from another system, including several forums with dozens of topics. However, they are not showing in the same order as in the original website, eventhough I carefully imported the dates and times of all topics and replies. The problem seems to be in that the date taken for the “freshness” is that of my last editing. Is there a way to override this so that my freshness corresponds to the last reply?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The default ‘freshness’ is calculated by the last reply.

    Have you run each of the repair tools after your import?

    http://codex.bbpress.org/repair-forums/


    JuanISar
    Participant

    @juanisar

    I did not explain myself sufficiently.The import was fine, the issue appeared when I edited topic and replies from WordPress. It appears that the forum is showing the freshness based on the date of editing, not the date of last reply, i.e. much more recently (days vs. months).

    You shouldn’t be seeing this, I just tried to reproduce this and can’t.

    The repair tool ‘Recalculate last activity in each topic and forum’ explicitly does the repair on this when things get out of sync.

    We’ve been tweaking this particular section of bbPress for the next release and I have been up to my eyeballs in this particular piece of bbPress :O

    So speaking of ticket #1925 I have to have another look in the next few days in regard to imported topics and replies and I will see if I can find anything related to your issue whilst I’m at it.


    JuanISar
    Participant

    @juanisar

    I did go to the Tools as you suggested, and the issue was resolved, at least temporarily.

    Thanks for the follow up, let us know if the problem reappears.


    JuanISar
    Participant

    @juanisar

    It seems like that was the solution.

    There is still a small problem, which I am not sure if it is related or not, but I am posting it here, in case it is related.

    I just noticed that if I log in as a regular user, the first post is missing, while the replies are present. However, if I log in as the admin. I can see everything as intended.

    Is there a setting that I am not turning on or off?

    Thanks

    That sounds like you have a ‘membership’ plugin for managing your users permissions to access posts/pages/forums etc and is probably blocking access to normal users.


    JuanISar
    Participant

    @juanisar

    The membership I am using is Wishlist Member, so perhaps you are right. I have contacted them and they reassure me that there is nothing apparently wrong with my installation of their software. They even looked under the hood, so-to-speak, in my website. The thing is, the members can log in fine and see the replies, just not the topics, which would suggest a problem of compatibility with bbPress.

    Is this one of those cases when 2 plug ins just do not tolerate each other very well? have you heard of anyone having a similar issue?

    Thanks for your patience with me.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.