Skip to:
Content
Pages
Categories
Search
Top
Bottom

Topic "Views" is not counting


  • minervaa
    Participant

    @minervaa

    Hi all,

    I am using a a little bit customised hybrid theme. Suddenly it stopped counting the topic “Views”. That means regardless how many times you click on the topic it shows nothing. The field is empty. I have tried it from different computer and IP too but it just doesn’t count.

    I would appreciate of anyone help how I can solve this.

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)

  • _ck_
    Participant

    @_ck_

    Topic views will not increase if you keep viewing the same topic.

    Look at other topics and then come back to it.

    If it still fails to update it may be broken sessions support on your server.


    minervaa
    Participant

    @minervaa

    Thanks CK.

    Actually I installed that in two different sites, both views are not working, the second reason seems more plausible.

    I am going to install them on a different server to check.

    Thanks again.


    minervaa
    Participant

    @minervaa

    Hi CK,

    As you advised, I newly installed the forum and template in another server. After activating your plugin “bb Topic Views” the view count on the latest disccusions is working, but it is not working on “Forum names” section. It just shows an empty column.

    Any idea why it’s not working on that part?

    Thanks


    _ck_
    Participant

    @_ck_

    Ah the forum part requires part of the My Views plugin to be installed I believe (most-least views).


    minervaa
    Participant

    @minervaa

    Hey CK, thanks again. I activated all of the “views” related plugins just to make it work.

    The “Forum” section views is working and showing the total number of views but if I click on the “Forums” it brings the list of discussions but again the views column are empty.

    I am quite confused as the list of the discussions are showing the views on the Latest Discussions list but when seeing them under “Forum” name none of them are showing the view counts

    Is there any other plugins I shall be using?


    _ck_
    Participant

    @_ck_

    It’s possible the template for the forum page has a bug or missing code, I vaguely remembering one of my themes having this problem in an old copy.

    You are using “the-hybrid” theme?

    Does your forum.php template look like this?

    http://pastebin.com/raw.php?i=CLpMG0UF

    (if not replace it)


    minervaa
    Participant

    @minervaa

    You are s superstar CK ! It’s workig perfctly now :)

    I have gone through every single line of my forum.php and your code, didn’t find anything (perhaps I missed something) then I just replaced them as you advised. Now they are working :)

    Thanks a million!

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.